Pirate 4x4 banner

1 - 8 of 8 Posts

·
Registered
Joined
·
10,473 Posts
Discussion Starter #1
Hello,
Been working on a friend's '75 Cherokee. Ever since I brought the jeep back from its long sleep, I had a bit of binding when making tight turns. First it was the E-drive that was activated and when that was un-selected, it mostly went away. What little there was left, I assumed it was from the QuadraTrac clutches sticking.

Yesterday that binding turned into a loud cyclic banging noise when making tight turns. I lifted the front end and it appears to come from the front passenger side. It will make no noise when going straight, but as I turn the wheel, it will appear, then becomes worse the tighter I turn. It is binding so bad that I can see the front springs twisting.

I disconnected the front driveshaft and when I turn the front yoke by hand, everything turns smoothly. Under power it does bind quite loudly.

I had rebuilt the front axle (bearings, seals, u-joints) and I thought perhaps that side's u-joint had seized. I pulled it out and it feels brand new.

My thought was that perhaps something I did caused the center axis of the u-joint to shift from the kingpin's center axis.

Any thoughts?? Thanks.

https://www.youtube.com/watch?v=343Qgfu9z6k
https://www.youtube.com/watch?v=KjCYGyJcLs4
 

·
blatant asshole
Joined
·
11,690 Posts
What does it have for locking hubs?
How is the spindle brg?

It sounds like the shaft is hitting the lower balljoint tip.

Are all the stub shaft thrust washers in place?
Is the stub held tight up the the back of the spindle?

Is that the original shafts or was it originaly a 260 ujoint setup and now its a 297/760?
 

·
Registered
Joined
·
10,473 Posts
Discussion Starter #3 (Edited)
What does it have for locking hubs? Drive flanges - Full time T/C
How is the spindle brg? It was replaced 1000 miles earlier. Looked fine today

It sounds like the shaft is hitting the lower balljoint tip. That was my thought too, but there is clearance. No signs of rubbing anywhere either

Are all the stub shaft thrust washers in place? I believe so, but I will double check
Is the stub held tight up the the back of the spindle? It's pushed by the spring inside the hub

Is that the original shafts or was it originaly a 260 ujoint setup and now its a 297/760?Original size u-joints Original shafts.
Thank you.
 

·
Registered
Joined
·
10,473 Posts
Discussion Starter #4
This is what I have.



I had mounted the drive flanges backwards (relief facing inwards). I reversed them, but the problem is still there.
 

·
Registered
Joined
·
4,328 Posts
Turn the 4wd lock off in the glove box.
 
1 - 8 of 8 Posts
Top