Pirate 4x4 banner

1 - 5 of 5 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #1
Any of you guys no anything about working on a dirtbike? My wifes 90 KDX 200 was bogging pretty good at 1/2 throttle and above and blowing white smoke out the tail pipe. To try to fix it, I put in a new piston, rings and top end gaskets, and spark plug. I thought the white smoke may be coolant, but my coolant level is/was always full, so thats out. The old plug was wet fouled and stank like fuel so I put a new one in. Still the same issues...I am going to lower the float levels, and try to re-jet the carb though I have never done that before. Do you guys have any other ideas what it could be?

I will also be rebuilding my RM this weekend if nobody goes out wheeling. Anyone have any tips? Never tore her apart before...
 

·
Registered
Joined
·
1,848 Posts
what type of spark arrestor are you running?

if it's a screen type it could be clogged.

i used to burn the screen out in the BBQ with a propane torch then blow it out with compresed air after it had cooled.
 

·
Registered
Joined
·
313 Posts
Sounds like you have a leaky crank seal. Gear oil is being sucked through and being burned. Have the engine pressure tested to confirm. You can also try this, remove the oil fill plug and place your finger over the hole and see if you notice any suction while the engine is running.

The older Kawasakis have the seals on the inside, so to replace it you will have to split the cases.

With a good manual you should be able to rebuild the RM no problem.
 

·
Registered
Joined
·
1,560 Posts
Hawaii500_1999 said:
what type of spark arrestor are you running?

if it's a screen type it could be clogged.

i used to burn the screen out in the BBQ with a propane torch then blow it out with compresed air after it had cooled.
I'd second this option of troubleshooting from my experience if in fact you do have a spark arrestor.
 
1 - 5 of 5 Posts
Top