Pirate 4x4 banner

1 - 8 of 8 Posts

·
Registered
Joined
·
410 Posts
Discussion Starter · #1 ·
I have a 93 Wrangler with the 4.0 and it wants to stall when i brake hard or come to a stop real fast. Any ideas what might be causing this to happen
 

·
Premium Member
Joined
·
1,299 Posts
If I have to take a guess I would say it is one of the following... throddle position sensor (TPS), idle air control (IAS) or the speed sensor in the t-case. You should run the check engine sequence for codes. Do a search for the proceedure and codes or buy a factory service manual.
 

·
Registered
Joined
·
12,465 Posts
Originally posted by DE Jeeper:
<STRONG> Do a search for the procedure and codes or buy a factory service manual.</STRONG>

I agree...start with the codes <IMG SRC="smilies/wink.gif" border="0"> The cheap ass Haynes manual has the process you need.
 

·
Registered
Joined
·
7,069 Posts
I think that in 93 you can check the codes buy turning the key on, off, on, off, on then count how many times the Check Engine light flashes. It will have pauses between codes. flash pause flash flash means Code 12
 

·
Registered
Joined
·
99 Posts
if it wont idle eiher sounds like the TPS to me.
 

·
Registered
Joined
·
337 Posts
I had a similar problems. Hook a pressure gauge to the injection tube, should run around 30LBS. Mine was 70, found out that I smashed the skid plate up into the fule tank causing the return for the EFI to be pushed against the tank causing the pressure to raise because it couldnt release itself. Unfortunatly had to pull the take to fix everything.

BlueYJ <IMG SRC="smilies/glasses.gif" border="0">
 

·
Registered
Joined
·
410 Posts
Discussion Starter · #7 ·
Ok i checked the engine codes and came up with 12-33-21-15-55. I have gathered that 12 means i accessed the system and 55 means end of codes but i am not sure if i have the other codes right because i could only find a TJ engine code chart.

33-An open or shorted condition detected in the duty cycle purge solenoid circuit.

21-Something to do with the oxygen sensor not working and running above temp

15-No vehicle speed sensor signal detected during road load conditions.

I have no idea what 33 is telling me.
Does 21 mean i need a new O2 sensor? I dont want to replace it if i dont have to because it is 75 bucks.

15- explains why my speedometer isn't working but is it saying my speedometer is broken or something on the t-case end.

Thanks Jim (93 YJ)
 
1 - 8 of 8 Posts
Top