Pirate 4x4 banner

1 - 10 of 10 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter · #1 ·
It Sunday morning Aug 26th...

My not so mechanically inclined brother in lay id dead in Helena Montana with by new BJ60.... He was going down hill and suddenly no drive. I thinks its a linkage problem but now way to tell.


Need any expert opinion out there

Call me Collect .... (503) 735-4945

Just say cruiser guy to the operator

Thanks

Chris Brandt
 

·
Premium Member
Joined
·
4,526 Posts
did he put the t-case in neutral??? btwits a FJ60 not a BJ60 right?
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #3 ·
Poser its a BJ60....

Traded for this thing unseen and is my 1st toy...

Whats your # need to talk to somebody who knows the linkage...

Chris
 

·
Premium Member
Joined
·
4,526 Posts
ive never worked on a bj before. i just hought he could have hit the t-case lever by mistake or something.
 

·
Registered
Joined
·
1,345 Posts
On the forties, you can just crawl under it and pop the lever in gear on the transfer case itself. There should be something like that on yours too, just crawl underneath and move some levers, but make sure the tranny is in neutral first. sorry I dont know specifics, I have never seen underneath a 60
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #8 ·
Have done a bit of troble shooting and still no luck .

What is the angle of rotation of the range select lever on a split case ?

I need a Helena Mt Cruiser guru...
 

·
Registered
Joined
·
1,345 Posts
dude, sorry you couldnt get it going by now. what are the exact symptoms in detail and maybe someone can narrow it in for you. are you sure its the linkage? did you ask the guy you bought it from? It may have happened before.
I looked through my haynes manual, but it doesnt have a split case or anything helpful in the troubleshooting that I say (what a suprise) <IMG SRC="smilies/biggrin.gif" border="0">
Once again, on my forty (which may not be the same) the lever is on the top passenger side of the t-case and has about a 90 degree movement. with neutral being in the center and high and low on either end.
Hope you get it figured out an let us know what it is, when you do.
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #10 ·
An update for the group...

Diagnosed the problem as a broken main input shaft or the cluth hub is tore out... How and the hell does that happen coasting down hill ?

No connection between the engine and tranny, any other suggestions.

Brother-in-law is driving here in a rentak car and I am making a turn around trip on the weekend with a car trailer.

Why are things never easy ?

Anybody with a spare hf55 for sale cheap ?


Thanks to everbody who responded with emails and phone calls. Nobody called collect either... A classy bunch no matter what the Jeep guys say about you

<IMG SRC="smilies/tongue.gif" border="0"> <IMG SRC="smilies/tongue.gif" border="0">

Thanks again

Chris
 
1 - 10 of 10 Posts
Top