Pirate 4x4 banner

61 - 80 of 88 Posts

·
Registered
Joined
·
999 Posts
Discussion Starter #61 (Edited)
Let me say Tahoe rear springs up front with 63" chevy springs in the rear, match up perfectly on ride height for 37s. The front springs are super flex but without the overloads in place they want to go negative, so bump stops will be in order. Also ran out of height on the cherry picker but I am sure she has way more in her.

Everything tucks real nice, but a bit of fender trimming will be needed





 

·
Registered
Joined
·
999 Posts
Discussion Starter #62
Exhaust work now I know how this thing is going to flex and how the front driveshaft is going to travel.

I was able to get the passenger to driver side crossover to fit between the atlas and transmission and not hang down any lower then the pan on the transmission.





The two sides will be tied into each other using v-band to make removing the exhaust easier in the event that I need to drop the transfer case and/or transmission.

Exhaust crossover and muffler.



 

·
Registered
Joined
·
999 Posts
Discussion Starter #63
Swapped a FJ80 rear axle into place. Also took advantage of Ruffstuff's Memorial Day sale and bought their spring perch and u-bolt kit to make things easy.







 

·
Registered
Joined
·
999 Posts
Discussion Starter #64
Did get the FJ62 tank with the modified GM pump put into place and everything clears nicely. Only issue I had was assembling the PTFE AN fittings and ended up screwing the threads up on the first one.

 

·
Registered
Joined
·
999 Posts
Discussion Starter #65 (Edited)
Fuel line routing.









Mounted up the evap canister purge valve as well. I plan on mounting the canister itself in between the intake and firewall in the big void. Looks like a few people have mounted it there with no issues.

 

·
Registered
Joined
·
999 Posts
Discussion Starter #66 (Edited)
Finished all of the wiring for the motor on the driver side. This included getting the ecm mounted, bussman fuse block mounted, and the factory body harness cleaned up. Also finished all of the inside connections for the ODBII port, "Choke" Engine light, and the TCC brake switch.

Rigged up some power to a spare battery to check functionality of the system and my wiring. At first I had not power and nothing was working. Silly me, I forgot to hookup the grounds for the relay block. Once that was addressed, the fuel pump cycles on and I can interface with the computer using TorquePro.

Now I just need to plumb in my trans cooler and I can test fire the motor.



 

·
Registered
Joined
·
999 Posts
Discussion Starter #67
Finished up mounting the trans and power steering coolers:



As well as the resting of the plumbing and the final piece of engine accessory, the Vortec cover. Did have a little hiccup when I first filled it up with coolant as the old water pumps was bad and leaking, so I put in a new pump as well. Figure it is just extra insurance.





On a side note, I jerry rigged up some battery cables and and low and be hold after a few cranks she fired right up. Has good oil pressure, idles great and is not throwing any codes yet. Also about half of the monitors were set so that is good news.

All that is left before the first test drive, is to finish the batter box and cables, then bleed the brakes.
 

·
Registered
Joined
·
999 Posts
Discussion Starter #68
Runs great but I still have a bit of work to do.
Needs rear shock mounts and the brakes bleed again. Might actually need to install a different master cylinder as I dont think the FJ60 one has enough power for the FJ80 rear axle with disk brakes.

Also I am getting a bunch of rear drive line vibration. Initially I only noticed when I let of the gas at any speed, but once I got out on the main road and above 40 mph it was really bad on and off the gas. I think the rear shaft might need new u-joints as there is about 1/16" of lateral play in the joint. I.e. the caps are tight in the yoke, but the joint can move side to side in the joint.

Also notice during the test drive a couple more of the engine monitors were set. I think there are only 3 left and no check engine light yet.

 

·
Registered
Joined
·
999 Posts
Discussion Starter #69
Ended up swapping out the stock FJ60 master cylinder for a FZJ80 master and that made a work of difference on far as pedal feel and how well the brakes work now.

Also finally sorted out my driveline issues. I sacked up and had a new driveline build by B W Driveline in Aubirn, CA. These guys were great, extremely quick, and responsive. I even got a heads up call from Bud, to let me know that my driveline would be done in 20 minute. Talk about customer service. We ended up going to a 1350 CV at the T-case and a standard Toyota joint at the differential. The nice thing is, when I go to one ton axles I will just need to change the slop out to a 1350 style and be good to go.







During the first test drive, it was a night and day difference. Where anytime with the old shaft I would have vibrations when letting off the gas. Also I could not get above 45 without it sounding like everything wanted to explode. With the new shaft I did have a little vibration here and there but very faint.

In order to fix this, I ended up cutting the perches off the rear axle and rotating the pinion up to aim at the t-case flange. Something I figured I would have to do. Once I did this I had no vibrations up to 65 mph, havent gone faster than that as I still dont have rear shocks. I did order a set of Bilstein 7100s with 275/78 valving for the rear.
 

·
Registered
Joined
·
999 Posts
Discussion Starter #70
After doing a bit of research, ended up ordering a pair of Bilstein 7100s for the rear. I ordered them in the 14" 275/78 flavor. Due to the length I also built a new shock tower.









Even with the new tower the shocks are a bit too long. I plan on ordering a set of 12" 7100s and moving the 14s to the front.
 

·
Registered
Joined
·
999 Posts
Discussion Starter #71
Well today is the big day, the dreaded appointment with the CA BAR Referee. I have been driving the cruiser for the last few days to and from work and everything has been great. Drive decently but does need new front shocks and had a few leaks. One was from a bad trans pan gasket, which I replaced with a lube locker gasket. The other was the rear hub seals were bad, so i replaced everything last weekend and repacked the bearings.

So far all of the emission monitors have set except for the evap monitor, which from my understanding on 2000 and newer vehicles is not required to be set. Through this process I have had zero check engine lights or pending codes, so I am pretty confident all systems are working properly. However, who knows what the referee is going to knit pick on.
 

·
Registered
Joined
·
999 Posts
Discussion Starter #72
Well things didn't go well.

Was nailed on a couple of things:
1: Evap Monitor was not set, I guess for motor swaps this need to be complete. Also had 2 pending codes but none of my scanners can read them. He would not tell me what the codes are.

2: I was told I am not allowed to modify the exhaust at all, from the exhaust manifold flanges till the rear 02 sensors. I asked him about this due to the frame being in the way and I was told that I would have to cut my frame as that is how BAR wants it? This cant be right I as I was under the impression that as long as the Cats were in a few inches of their original location it was ok.

3: Said I modified the ECM as I had VATs removed and this is not allowed. He told me I have to install the entire body module from the donor vehicle and the ECM can not be flashed in any manner. No idea on this one. Said I needed to supply documentation from the dealer showing the vehicle has the correct ecu/flash?

4: Said the motor needed air injection. The ECM and harness that came with the motor did not have air injection so I am confused on this one. His scan showed a 2001 5.3, so are there any configurations out there without air injection? I had a buddy pull the vin on the way home 1GCEK19T41E122562. Does anyone have a way to verify the emissions requirements for me?

Only good news is it passed on the dyno and all measured emissions were low. What I dont get is why cant I get a pass when the new motor runs cleaner than any old tired 2F out there?





At this point I am lost and defeated. Any advice would be greatly appreciated as I am not sure where to go from here.
 

·
Registered
Joined
·
999 Posts
Discussion Starter #73
Ok,

So I emailed Brendan at LT1Swap.com , who did my ecm programming about if he removed the air injection.

Here is what he said:
"AIR injection was only on CA emission equipped gm trucks. Federal emission trucks never had AIR injection. 2002 did away with EGR on all 5.3l engines. My notes say it was with EGR, so 2001 would be correct. The calibration in your PCM did not have AIR injection. EGR YES"

So my next question is, if the motor was a federal motor then in order to swap it into a CA compliant vehicle does it need the air injection?

Thanks
 

·
Registered
Joined
·
505 Posts
Ok,

So I emailed Brendan at LT1Swap.com , who did my ecm programming about if he removed the air injection.

Here is what he said:
"AIR injection was only on CA emission equipped gm trucks. Federal emission trucks never had AIR injection. 2002 did away with EGR on all 5.3l engines. My notes say it was with EGR, so 2001 would be correct. The calibration in your PCM did not have AIR injection. EGR YES"

So my next question is, if the motor was a federal motor then in order to swap it into a CA compliant vehicle does it need the air injection?

Thanks
If you get your vehicle BAR'd as a 2001 engine then you would need the air injection. If 2002 does not have air injection then you may be able to use a 2002 ECM that does not require it instead of trying to add air injection in.
 

·
Registered
Joined
·
999 Posts
Discussion Starter #75
Adding the air injection would not be hard. Only real issue is I would have to send the computer back out to have the controls added in. This might be the better option as the camaro manifolds already have the ports, and the ref would most likely over look the fact that they are not truck manifolds.
 

·
Registered
Joined
·
999 Posts
Discussion Starter #78
Decided to bite the bullet and install the secondary air injection. Is there anyone local to Sacramento, that has Hptuners or Efi Live that is willing to help me out? I need the air injection system enabled in my ecm.
 

·
Registered
Joined
·
999 Posts
Discussion Starter #79
Said screw it and bought HpTuners. Figured it made more sense in the long run to be able to trouble shoot and tune in my driveway as opposed to relying on others.
 

·
Registered
Joined
·
3,327 Posts
That sucks about the smog stuff, I wish I could help but we don't really have that here.

Sweet build though, I saw it a few months ago and haven't checked back in until now. This is pretty much the exact route I want to go with my Fj62 for a DD/wheeler type of thing. How do you like the suspension? Everyone on Mud is OME or die, and I just don't buy that. I'm wondering how well those springs would SUA as they are junkyard available and I could avoid the cut/turn on the front axle for a while.

Keep the updates coming.
 
61 - 80 of 88 Posts
Top