Pirate 4x4 banner
1 - 20 of 66 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
I flipped it into a pond over a 5 foot underwater cliff. So it takes us an hour to pull it out and I've been working on it for a week getting it running.

I drained the oil and replaced it. I have replaced the entire distributor set up cause it was shorted out from the water. That didnt get it running so i took out the spark plugs and turned it over shooting the water out. Replaced the plugs and the wires to the distributor. Still didnt work and i had a nasty squel coming from my ignitor coil. I replaced the ignitor coil thinking that would do it. Cured the squel and tuned over the engine for the first time with starter fluid shot into the top of the engine.

Realized that there was still water in the fuel. Drained all the fuel and replaced it after putting Iso Heet into the fuel. And thats where I am at right now. Still not running.

Any ideas?


 

·
Registered
Joined
·
21 Posts
Discussion Starter · #4 ·
Yeah, I was over eager and tried to start it right away. And I got spark and fuek is flowing.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #6 ·
No its a carb. There isnt much of an ecu, its gotta be something mechanical. Yeah the dog in that pic is on the shore.
 

·
Registered
Joined
·
872 Posts
GREAT PIC!!!! So....ahhhh how'd the snorkel do? J/K

Pull the pan, clean everything, hoses???? fuel filter replaced? Carb rebuilt? Pull the cover and look at the head... Could be a mess of crap in there...Clear out the exhaust system too....
A splash of water here and there is not to bad, but you kinda took it to another level here... I'd replace the oil in the diff's and tranny/tcases at the vary least before you move it much more (Towing)

Glad you got out ok too!!....
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #9 ·
Cleaned pretty much everything but its not making any bad noises. It sounds like its running smooth. But I replaced the fuel filter, and checked the fuel hoses and its running all the way past the fuel pump. The engine runs but only off of starter fluid.
 

·
Registered
Joined
·
1,419 Posts
Any ideas?
At least you know your battery doesn't need more water for awhile.

Do you have the plug wires on in the right order? God only knows what's stuck in your carb after sitting in water that long - might wanna check that too. Will it start without the air filter on? That thing could be mega-clogged, restricting air - which would make sense if you've got fuel and spark.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #11 ·
Im not sure that im getting fuel cause i can spray starter fluid in the top of the carb and it will start. Air isnt blocked at all.
 

·
Registered
Joined
·
1,375 Posts
AHAHAHAHA....Love the user name you picked, very fitting!!!

No offense, but man i wish i could have seen that!!

Try throwing a different carb on it.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #13 ·
I dont have another one. Yeah, it was me and my buddy Jay and i creeped about a foot in and my truck got sucked under and sideways. i climbed out my side window and jay went and to go get his truck a hundred and fifty feet away to pull it back over. By the time he got back it was upside down 4 feet from shore.
 

·
Registered
Joined
·
11,586 Posts
No its a carb. There isnt much of an ecu, its gotta be something mechanical. Yeah the dog in that pic is on the shore.

It runs on starter fluid so it is fuel related.

Did you take the carb apart and clean it? If you get water in the carb the fuel floats on the top and it takes a LOT longer then you would think to suck that water out if it even can get it all out.

Is the choke opening?

Factory carb it has more electrics then you realize and that ECM under the passenger seat has a lot more control then you think. The factory carb has a anti diesel circuit that cuts fuel flow. Your problem is that ECM that you discounted and water in the carb.
 

Attachments

·
Premium Member
Joined
·
23,549 Posts
good thing you had your snorkel on it:flipoff2:
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #16 ·
yeah, i think i installed it wrong though, it didnt work when i was upside down.
 

·
Registered
Joined
·
11,586 Posts
yeah, i think i installed it wrong though, it didnt work when i was upside down.
:laughing:



At least you got a sense of humor about it!
 

·
Premium Member
Joined
·
16,324 Posts
could of drove out if you had fuel injeciton

were you in the truck when it sank? that must have been a ride.
 

·
Registered
Joined
·
380 Posts
Im not sure that im getting fuel cause i can spray starter fluid in the top of the carb and it will start. Air isnt blocked at all.
Same thing happened to me, take the top half of your carburetor off and get some compressed air going through those inlets and jets. Just don't be yancy and rushed about it looke where all the passages go. Same thing happened to me from water in the tank.
 
1 - 20 of 66 Posts
Top