Pirate 4x4 banner

1 - 8 of 8 Posts

·
Registered
Joined
·
193 Posts
Discussion Starter #1
'96 XJ here and here lately I've had just a few instances where the truck hesitated to go just as I gave it some gas. Only been seeing this from dead stop or slight roll. Hesitates for a second or two then it gets going like normal.

Did it again this morning and although I haven't been paying attention to the dash lights I noticed the GEN light was on just before I shut it off. It could've been on since the hesitation on start up, not really sure.

Are these two things related and what does the GEN light mean? Check engine light isn't on and my reader doesn't show any codes right now. Put in a new alternator 3 years / 25k miles ago.
 

·
Registered
Joined
·
289 Posts
'96 XJ here and here lately I've had just a few instances where the truck hesitated to go just as I gave it some gas. Only been seeing this from dead stop or slight roll. Hesitates for a second or two then it gets going like normal.



Did it again this morning and although I haven't been paying attention to the dash lights I noticed the GEN light was on just before I shut it off. It could've been on since the hesitation on start up, not really sure.



Are these two things related and what does the GEN light mean? Check engine light isn't on and my reader doesn't show any codes right now. Put in a new alternator 3 years / 25k miles ago.


Bad cell in battery???


Sent from my iPhone using Tapatalk
 

·
Pirate hooker
Joined
·
61 Posts
The hesitation is most likely from a failing upstream o2 sensor, the gen light should be investigated as it sounds like your alternator is failing.
 

·
Registered
Joined
·
193 Posts
Discussion Starter #6
Thanks everybody. Funny yeah that thread's actually mine. I usually ask around in a couple places when I'm in a hurry. Moneys always on the line when my vehicles are down. Anyway like the other thread explains it turned out to be my alternator. Can't believe it went bad after only 2 years. The one that came out of it back then was the original and it lasted 20. This one's got a lifetime warranty so it was free to replace, but what's my options for not replacing this one every 2 years now?
 

·
Registered
Joined
·
289 Posts
Thanks everybody. Funny yeah that thread's actually mine. I usually ask around in a couple places when I'm in a hurry. Moneys always on the line when my vehicles are down. Anyway like the other thread explains it turned out to be my alternator. Can't believe it went bad after only 2 years. The one that came out of it back then was the original and it lasted 20. This one's got a lifetime warranty so it was free to replace, but what's my options for not replacing this one every 2 years now?


Don’t buy from oreillys!!!
Yes they have lifetime warranty!!!
But they’re chit products, especially electronics!!!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
668 Posts
If you can find one in the junk yard, an alternator off a '98 5.9 ZJ is 150 amps stock, you just need to swap the pulley and the plastic insulator on the main battery cable to fit it to the 4.0l XJ. A V8 or V10 Dodge truck of the same vintage will usually have a 136 amp alt. Both alts have the large case, but will fit perfectly on the 4.0l brackets. XJ's with a/c usually come stock with a 105 amp small case alt.

If you buy reman units, I've had good luck with the Denso brand at my work. Denso is OEM on these. Most of the time you can buy the reman high amp unit then turn in the small case core, if you bring it back the next day they won't see the different size case. :grinpimp:
 
1 - 8 of 8 Posts
Top