Pirate 4x4 banner
1 - 11 of 11 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 · (Edited)
Ok I checked everything out and even replaced the O2 senser. I drove it for about 8 miles at about 65 to 70 and when I got home I looked up under the driver side wheel well and sure enough it is still glowing orange but not near as bad as it did before I replaced the TPS man it was bad then. I wonder if they do glow a small amount and nobody has ever looked. If someone gets a wild hair take out your truck and see if it glows after around 10 miles or so, and let me know. Just make sure your not near any lights when you look. Its a 1989 with a brand new 22re from head down. This is messing with my mind. It runs great and has all its power. I'm just not sure. Thanks guys!
Scott
 

·
Registered
Joined
·
2,721 Posts
something is wrong with your truck. it is not supposd to glow at all. sounds like its running lean to me. did u search at all? i know this has been bought up before.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #4 · (Edited)
Did a search can't seem to find anything on hot exhaust manifold. I did take of my Cat and it has been hollowed out it is just the shell of one. The O2 senser is before the cat so I don't believe that should make much of a difference. No codes in computer either. I'm just at a complete loss. HELP!
Scott
P.S. My timming is between 5 and 7.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #6 · (Edited)
LOL, Yep the freakin fan is turning. I let it idle for 15 min or so and it doesn't turn red at all. One more wierd thing is that when I put my foot on the gas pedal and rev it to around 1400 rpm's, the rpm's climb and drop climb and drop. Rev it any higher and smooth as silk. Also at idle smooth as silk. I check in the search again and seen were some people say its normal for it to glow when you are in a dark place with no lights around. Not sure it thats right or not but you never can tell. I'm sure not many people look at the manifold from under the truck when it really dark outside.
Scott
P.S. Is retarded timing further to the left of top dead center or closer to Top dead center?
 

·
Banned
Joined
·
4,587 Posts
Diek said:
LOL, Yep the freakin fan is turning. I let it idle for 15 min or so and it doesn't turn red at all. One more wierd thing is that when I put my foot on the gas pedal and rev it to around 1400 rpm's, the rpm's climb and drop climb and drop. Rev it any higher and smooth as silk. Also at idle smooth as silk. I check in the search again and seen were some people say its normal for it to glow when you are in a dark place with no lights around. Not sure it thats right or not but you never can tell. I'm sure not many people look at the manifold from under the truck when it really dark outside.
Scott
P.S. Is retarded timing further to the left of top dead center or closer to Top dead center?
P.S. Is retarded timing closer to Top dead center? :D
 

·
Registered
Joined
·
909 Posts
Try reading the plugs to verify lean. Try adjusting your afm richer. Try to adjust idle speed screw to run it at 1400 RPMs, then play with the AFM to see if you can smooth it out. Check all AFM and TPS connections, maybe you frayed a wire while R&Ring the engine. Also while running at 1400 shoot propane around all the air ducts between afm and throttle body. And everywhere there's gaskets from the head to the throttle body. Try resetting the ecu.

Just some ideas.
 

·
Registered
Joined
·
517 Posts
I'd check for air leaks in the intake system after the sensor. Air not registered by the sensor and throwing off the balance. No they aren't SUPPOSED to glow!
:flipoff2:
 

·
Registered
Joined
·
99 Posts
my old 22re manifold used to glow after a WOT run up a long hill...
 
1 - 11 of 11 Posts
Top