Pirate 4x4 banner

1 - 20 of 25 Posts

·
Registered
Joined
·
948 Posts
Discussion Starter #1
Anyone know how to set up the wiring for GM TBI with a HEI Dist??
 

·
Registered
Joined
·
948 Posts
Discussion Starter #3
I wired up the Dist and now have no fuel.
 

·
Registered
Joined
·
1,011 Posts
GM TBI is already HEI it just has a remote coil and small cap rather than the coil on top of the large cap.

Also, if you did not do anything with the Ignition Control Module that was in the original distributor, the computer will get no signal for spark and will not fire the injectors.

Dik
 

·
Registered
Joined
·
948 Posts
Discussion Starter #5
Is their a way to bypass this?
 

·
Registered
Joined
·
948 Posts
Discussion Starter #7
Trying to make it run right, It acts like like there is no Advance curve.
 

·
Premium Member
Joined
·
15,352 Posts
Trying to make it run right, It acts like like there is no Advance curve.
If thats the case put the old dist back in because I will put $$ on it its not your dist. There is only one factor that can cause it--and you will get a code 42(typicly) due to the est/bypass signal lost either due to a wiring issue or the ignition module
 

·
Premium Member
Joined
·
5,281 Posts
Trying to make it run right, It acts like like there is no Advance curve.
The advance on TBI is completely computer controlled. Even if you convert to the large cap HEI, you will have to lock out both the mechanical and vacuum advances.

x2 on "it's something else"

Get your module tested at the auto parts store
Make sure all wiring is in tact
Make sure the bypass plug is connected/in tact (single terminal) weatherpac on a brown/black stripe wire going to distributor)
 

·
Registered
Joined
·
4,050 Posts
not all tbi systems use an electronic advance disy - the early 454 tbi had a HEI, with a mechanical advance --

do you have a electronic advance system ? are you using a 7 pin ignition module ? is the disy mechanical advance locked or removed ? get a system diagram and check the wiring - what engine and year harness ?
 

·
Premium Member
Joined
·
5,281 Posts
Interesting, didn't know about the advance on the 454s.

From the link in his sig it looks like it's an 88 burban with a TBI 350. I'm sure he'll chime in to verify this, but from reading his build thread it sounds like he's already set the initial timing to 0 (bypass disconnected).

His last post says he swapped out the ECM and it ran fine for 5 mins then started messing up again. Is it possible there's a bad oil/water temp sensor that's sending the ECM into limp home mode?
 

·
Premium Member
Joined
·
15,352 Posts
not all tbi systems use an electronic advance disy - the early 454 tbi had a HEI, with a mechanical advance --

do you have a electronic advance system ? are you using a 7 pin ignition module ? is the disy mechanical advance locked or removed ? get a system diagram and check the wiring - what engine and year harness ?

Really? When GM introduced the TIB setup on the 454 they also integrated timing into the dist/ecm. I have never ever seen a factory setup that used the early HEI....
 

·
Registered
Joined
·
948 Posts
Discussion Starter #16
Put the Original back in. Got it running. Finally got the Code reader working.
Got code 33. Map sensor. replaced it, Cleared codes, and i get the same code.
 

·
Premium Member
Joined
·
15,352 Posts
Put the Original back in. Got it running. Finally got the Code reader working.
Got code 33. Map sensor. replaced it, Cleared codes, and i get the same code.

Throwing parts at it doesn't mean its going to fix it :D

Try looking at the circuit--pretty easy. 5v feed, return voltage and a ground to the ecm...
 

·
Registered
Joined
·
4,050 Posts
Really? When GM introduced the TIB setup on the 454 they also integrated timing into the dist/ecm. I have never ever seen a factory setup that used the early HEI....






i have a customer that has one - its a 85 by the vin, but says 86 on the emission sticker - i noticed it because the vaccum diagram showed an advance, then confermed when i did a tune up - only a power and tack lead out of the dizzy, with an advance - its the only one ive seen in person.


and a 88 burban with a tbi 350 - ill get you an ecm diagram - dose the map sensor have vaccum ? no leaks to it ? 5 volt, ground and signal ? ill get a few pics
 

·
Registered
Joined
·
4,050 Posts
the ecm diagram
 

Attachments

1 - 20 of 25 Posts
Top