Pirate 4x4 banner

1 - 13 of 13 Posts

·
Registered
Joined
·
621 Posts
Discussion Starter #1
.030 over 351w
stock rebuild w/ the mild extreme4x4 comp cam
external oil & tranny coolers mounted off to the sides
DUI distributor
performer intake w/ q-jet
flowcooler water pump w/ smaller pully
tripple bi-pass radiator
opend up engine compartment
wrapped headers

still have alot of engine compartment temperature wich makes it vapor lock

is it cam timming or what

ignition timming is about 30 deg at 2800 rpm
 

·
Registered
Joined
·
2,116 Posts
What temp is the engine running at? Electric or mech gauge? Fan shroud or no? What fan are you running? Have you checked your spark plugs, see if you've got an over-rich/over-lean condition?

Where is the fuel line routed? Whats the proximity to the headers? Have you tried putting wooden clothes pins on the fuel line? I know that sounds goofy, but its a good cheap heat sink for the fuel line, put 5 or 6 on each run of the fuel line through the engine compartment. Other key concern, what fuel pump are you running?

30deg at 2800 sounds about on par, maybe just a little bit fast , but it shouldn't be causing that much extra heat
 

·
Registered
Joined
·
621 Posts
Discussion Starter #4
yep, i pulled the hood and it help alot but still have some carb issues climbing steep grades
yep, real tight shroud. Derale 3800 cfm fan w/ electric pusher up front to help while crawling
had stock fuel line. changed to braded steel. goin back to stock w/ isulation

and yes, clothes pins about every foot.

temps are normall now that i have an external oil cooler. before in the summer crawls the water temp would go up then the oil temp would follow

never a probolem goin down the road and crawlin in the winter.

manual autometer oil and water gauges. electric oil and tranny gaugers
plugs are a little rich but its so damm hard to tell with todays fuel

had a stock fuel pump the bought one from summit cause i thought it might be starvin for fuel. q-jet is from jet performance. thinkin bout puttin the stock pump back on. why?
 

·
Registered
Joined
·
621 Posts
Discussion Starter #6 (Edited)
i pulled the hood and it runs fine. . hell, i dont know. or if i let it set in runs fine

my temps are normal, 180/190, after the exteral oil coolers and the triple bi-pass radiator
 

·
Registered
Joined
·
621 Posts
Discussion Starter #8
nothing is wrong with that. i have compartment heat the is causing the vapor lock. thats the probolem. no fule to carb, no run
 

·
Moderhater
Joined
·
23,463 Posts
nothing is wrong with that. i have compartment heat the is causing the vapor lock. thats the probolem. no fule to carb, no run
how is the fuel line run? i have a hard line from the fuel pump that goes near the steering box, and straight down the top of the frame rail. then goes to soft line near tank. i also have inboard headers.




do you REALLY want to fix this? get a fuel filter with a return on it, and make a return to the tank. it WILL fix this problem.
 

·
Registered
Joined
·
621 Posts
Discussion Starter #10 (Edited)
how is the fuel line run? i have a hard line from the fuel pump that goes near the steering box, and straight down the top of the frame rail. then goes to soft line near tank. i also have inboard headers.




do you REALLY want to fix this? get a fuel filter with a return on it, and make a return to the tank. it WILL fix this problem.
same. i think i'm gona buy some line insulation tape and see what happens. pump to carb was stock. i'm gona wrap it and put it back on. i got some braided hose now.

the filter with the return will stop the vapor lock?
 

·
Moderhater
Joined
·
23,463 Posts
just run the return back to the breather of the gas tank. you can get a t to make it fit in, or take the filler neck off and weld a little bung on it to put the fuel line back on. im telling you its going to work! my carb guy wouldnt tell me and reccomend it if it didnt!
 
1 - 13 of 13 Posts
Top