Pirate 4x4 banner

1 - 6 of 6 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
I am no expert on wiring, so I have only looked on a search here for some possible answers. Anyways, I have a friend who has an 07 sahara.....she uses it for a DD no offroading or anything like that, all stock to my knowledge. She ran into the grocery store the other day, came back out 15 min later and none of the controls on here steering column were working.....no blinkers, couldn't swap between high and low beam, couldn't turn on or off fog lights. She said the lights were on though, just couldn't control them, dash lights were dimmer than normal. So she turned it back off, while the key was on (second click, not started) everything worked as it should. Has anyone ever dealt with anything like this before? She dropped it off at her mechanic, just trying to help narrow down what it may or may not be. Thanks.
 

·
Registered
Joined
·
10 Posts
so she turned the car on (running) and nothing worked control wise, lights were on automatically, and dash was dim. then she turned it off and back to power on (not running) and everything worked fine?

That would lead me to believe it's something to do with her key switch. Perhaps a bad wire in there somewhere, and by going to start position it causes a fault in the circuit? Not sure. I don't know why the other switches wouldn't work, usually stuff like headlights are independent of the key (so you can have the lights on with the car off, and vise versa). Did the stereo have any trouble? That's getting power from the key switch usually, so if the stereo wasn't working properly too I would strongly suggest they take a look at the key. If it was, it's something in the column itself (I'd try to replicate the problem and I'd have to take a look at a wiring diagram).

I'm no electrician or anything, but I do do small engine repair and I see this kind of thing (on a simpler scale) from time to time. Hope that helps, wish I could be of more assistance to you. Let me know what you find too please.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #6
Thanks for the response. And not just being a dick first and foremost. Lol. She had it into her mechanic and here is what she wrote me back. " so apparently it was a switch... he had to replace both the levers for the lights/turn signals and for the windshield wipers. Guess its a known jeep prob - and crysler sells over 200 of them a week...guess thats a holy shit maybe they should recall???"

I thought that was pretty interesting myself.....I have a dodge, so I know of the woes of some of Chryslers Shit.......lol hopefully this can be helpful to ya in the future.

Sent from my C771 using Tapatalk 2
 
1 - 6 of 6 Posts
Top