Pirate 4x4 banner

1 - 3 of 3 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
I'm having a serious problem with my steering.I can only get 1/2 a turn either way sense i got hydro boost brakes.I've tried everything I can think of to fix the problem.I have a saginaw pump(single inlet/single outlet),hydratech hydro boost,and EB power steering box(all of setup is brand new).My steering works great if hydro is bypassed.I thought the hydro boost was restricting it but the fluid flows straight threw with the outlet hose off.I have the return T'd with the steering box goiung straight threw to the pump and the boost coming in the side.The pressure line goes from the pump to the drivers side of the boost,out the passenger side to the steering box,and then back to the pump.I drilled the orfice in the pumpo out a little bigger as the search said.I've tried bleeding with the wheels off the ground(no better).I don't know what to do.I need help please!!!THANKS
 

·
Premium Member
Joined
·
7,661 Posts
I don't know about the hydratech unit, but the Bendix hydroboost (found on all sorts of vehicles) has the high pressure inlet on the passenger side and the high pressure outlet and return lines both come out the drivers side of the unit (now, that is in America where the steering wheel in on the left side of the vehicle :flipoff2: ).
 

·
Registered
Joined
·
563 Posts
Yeah, sounds like your lines are reversed. Assuming the booster was mounted right side up, Hydratech does some weird stuff so maybe not. If the return nipple on the hydroboost is in the air, The it's Pump to Passenger side, drivers side to gear box. (as the other guy said, assuming this is left hand drive).
 
1 - 3 of 3 Posts
Top