Pirate 4x4 banner
1 - 8 of 8 Posts

·
Registered
Joined
·
478 Posts
Discussion Starter · #1 · (Edited)
O.K. first I will establish that I have read through MULTIPLE faqs and other posts of the such. Now, I was driving down the freeway at 75-85 mph for an hour or so. Then I get to a toll (bastards!) I notice that my idle is high. Of coarse as I push on the brakes I get the "Loping Idle". As I pull away from the toll and I shift I notice as I let of the gas to change gears my rpm's fall at a slower rate than normal. During the 7 hour trip the problem goes away and returns several times. I let the truck sit and when I start it cold there are no idle problems, until it warms up and it starts all over. Some times my idle will go up to around 2k and hold until i goose it. I checked the codes and a II....IIIIIIII comes up. I cant for the life of me tell if it means a 2, and an 8 or a 28. The link that is on this 4x4wire has shity explination of the code decifering. (I tend to over read things) NOW before anyone reply w/ the "did you check the tps" or throttle drum thingy or anything else like that. When the problem is occuring if you get out of the truck and physically push the throtle to see if it's stuck open it is not. If the tps was bad then I would not be able to time the truck properly because the idle would stay up because the throttle would not be reading fully closed. The O2 sensor should set off a perminate Check engine light and here I am w/ my d in my hand.....
 

·
Registered
Joined
·
2,202 Posts
Engine trouble

Hay give me a few and I try to come up with something
 

·
Registered
Joined
·
2,202 Posts
ok this is what it might be

There are several things.
1. Sticking throttle linkage.(most likely not)
2. Choke opened excessively at idle.(most likely not)
3. Idle speed incorrectly adjusted.(most likely not)
4. Valve clearances incorrectly adjusted.(could be)
5. Dash pot out of adjustment.(could be)
6. Fuel Pump.
7. Air intake

Now I will tell you a few more things but the problem is I don't know what kind of F#$KING toyota you have(your a dick for the way you wrote this and i'm a nice guy for telling you all of this.)
1985 4runner=open or shorted intake air themo senser circuit
1986 pickup=same
1987 4runner= intake air temp sensor singnal-open/short
if its a v6 lit me know i'll send you something else
 

·
Registered
Joined
·
2,202 Posts
ok?

Man does this dumb ass just put up questions and not give any info about the problem. (what kind of engine or reply) :flipoff2:
 
1 - 8 of 8 Posts
Top