Pirate 4x4 banner

1 - 7 of 7 Posts

·
Registered
Joined
·
273 Posts
Discussion Starter #1
I just finished up my hysteer set up on my 85 runner and when I started the truck i had no power steering and there was a lot of fluid coming out of the side of the box. It was coming out of a little hole that looks like it has a ball bearing in it. Im gunna try to find a pic of a box and point it out. does any one know what ive done? have i hooked it up backwards? any help would be greatly appreciated
 

·
Registered
Joined
·
273 Posts
Discussion Starter #2
Here is a pic of where it is leaking from, this is not my box but the same kind, some one has to know what ive doen wrong, maybe ive bleed it incorrectly or something.



 

·
Registered
Joined
·
273 Posts
Discussion Starter #4
I got a better pic of where it is leaking from off of allpros website
should it leak from there? or do i just have a screwed up box, if it is just screwed up could I just weld it right there?
 

·
Registered
Joined
·
864 Posts
Mine leaked right there like a siv, i finally tried drilling that little bb out and was gonna solder or jb weld it shut. Well lo and behold after taking the drill to it and all around it and having the thing to where it should fall out. Didn't come out. So I tried to start my truck up to blow the f&^%r out.

After I started it, it wasn't leaking any more and the BB stayed in place. So i let it run tried locking the diffs with the front locker and turning it in place to put some strain on it and still wouldn't after 20 mins of abusing it. So I finally just shut it off, threw some jb weld in there and called it good. Hasn't leaked in over a year now

I think mine was dropped right on that little corner and pushed that bb out of whack. I had tried almost everything to fix it till that finally worked. Sorry not much help to ya,

My toyota mechanic of 20 yrs said that was pressed in there after the box was machined or something and it was just there to close the hole up if I remember right, but hey its been over a year.
 

·
Registered
Joined
·
273 Posts
Discussion Starter #6
thats exactly what i think has happened to mine, i think mine was dropped on that corner, and the bb was pushed back, there is a dent on that corner and the bb must have gotten pusehd back, thanks a lot man, this makes my day, im just gunna tear the thing out and tear it apart and see if i can see that little bb from the inside. and mess with it a bit Thanks man
 

·
Registered
Joined
·
273 Posts
Discussion Starter #7
fixed it, i just ground it down and then beat the crap outa it with a hammer in frusteration. i think im just gunna end up putting a little weld there to make sure it doesnt go anywhere
 
1 - 7 of 7 Posts
Top