Pirate 4x4 banner
1 - 3 of 3 Posts

· Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
I just bought an 89 isuzu pickup over the weekend. It's a little rough around the edges, but seems to have a strong powertrain. I've had a sporadic problem with the ignition, though. Twice when I've gone to start it up, it just turns over and over and over. After looking it over, I couldn't find anything obvious and just got frustrated and left it. When I came back the next day, it started right up. I'm positive it's getting fuel, and it turns over really strong - it just won't fire up. I've noticed both times that it didn't start, it was fairly cold out. The dizzy cap, wires, and plugs are all brand new. I'm confused because it starts right up about 8 out of 10 times. Where should I look next? Thanks!

-Colin
 

· Registered
Joined
·
25 Posts
Discussion Starter · #4 ·
Yep, sorry - I completely forgot to mention - it's the 2.6 litre w/ FI. On my way to get a spark tester and fuel pressure gauge now. Also going to check fuel pump to make sure it comes on when key is in "on" position. Found a broken vaccum hose - fixed, but no luck.
 

· Registered
Joined
·
25 Posts
Discussion Starter · #6 ·
Sorry for the late follow-up on this one. Turns out the fuel pump was the problem. I was replacing the filter - while I had the fuel line off, I decided to try and turn it over. No fuel pushed out the line. Checked to make sure it was getting power (which it was), so I replaced the pump. All is well now. Thanks for your help!
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top