Pirate 4x4 banner

1 - 11 of 11 Posts

·
Man Child
Joined
·
24,725 Posts
Discussion Starter #1
I've got a small problem. My 92 Runner is a V6/auto. I replaced the trans with a rebuilt one out of a '91 P/U. When I did it I was an idiot and I didn't use my sensors and electrics. I used the ones that were on the trans when I got it. Now...it seems to drive OK in 2wd (although it did do a wierd lock/unlock the torque converter at 70mph thing a few times). My reverse lights do not work and the 4WD is not engageing. The t-case drops into low range but the ADD does not engauge and I don't get the green 4WD light on the dash. Of course I already got rid of the old trans. I'm not sure what sensors do what on the trans so I'm a little lost.

Got any ideas???


Thanks for the help.
 

·
Registered
Joined
·
1,024 Posts
Did ya re-attach the 2 vacuum hoses to your front diff? Also the green 4WD light will not cause the system to not work. It is just an idiot light. I never reconnected mine when I SAS'ed it. Check to see if all hoses are connected and that there are none hanging down or cut.
 

·
Man Child
Joined
·
24,725 Posts
Discussion Starter #3
I did redo all the vacum connections and wire tied them. I originally didn't think anything about the 4WD light not coming on because I figured it wouldn't effect the function. Then I got the truck out in the dirt and found that my front wheels weren't pulling. So...anymore ideas???
 

·
Man Child
Joined
·
24,725 Posts
Discussion Starter #5
I did make sure that the t-case is engageing and I have a set of Asin hubs in the garage so I may go that route.
 

·
Registered
Joined
·
399 Posts
ADD is automatic hubs, right? Why not just convert to manual?
 

·
Registered
Joined
·
177 Posts
This has nothing to do with your hubs. You don't have them anyway, you have flanges that permanently lock the wheel/rotor assembly to the CV. They don't lock/unlock at all, they can't.

Priest, I'd make absolutely certain that your t-case is engaging. Put the truck on stands and carefully double-triple check. If the t-case is engaging and the front DS is being powered, I would take that ADD actuator off, lock it, then reinstall it.

You could easily have 2 vacuum lines switched, which would prevent the ADD actuator from working. This mod takes just a few minutes and you'll wind up with 15 ft of vacuum line removed from your truck; a little more space in the engine bay; and a simplified 4WD system.

But really check that t-case. It uses clutch plates which can wear over time, and there is some slip built in. <IMG SRC="smilies/mad.gif" border="0">
 

·
Man Child
Joined
·
24,725 Posts
Discussion Starter #9
ADD is automatic hubs, right? Why not just convert to manual?

ADD (Automatic Differential Disconnect) and auto hubs are two different things. They work completely different.
 

·
Registered
Joined
·
399 Posts
Aw, my bad.
i knew that add was auto diff disconect, but i thought they meant auto hubs.
I got it know though!! <IMG SRC="smilies/beer.gif" border="0">
 

·
Registered
Joined
·
27,885 Posts
if you need any parts associated with a nonadd system i have the front diff and everything(except manual hubs) on the truck that your tranny came out of. i have no use for that stuff whatsoever and you are welcome to it if you need/want anything...toyfamily may have parts to the wiring harness on the cab off that truck that he may not need(not running the auto/v6 etc) if some of the sensors are there you need?? <IMG SRC="smilies/wink.gif" border="0"> <IMG SRC="smilies/wink.gif" border="0"> lemme know...
 
1 - 11 of 11 Posts
Top