Pirate 4x4 banner

1 - 11 of 11 Posts

·
Registered
Joined
·
215 Posts
Discussion Starter #1
After sitting around for almost 2 years, my injectors on my 96 LT1 were pretty clogged up. I bought a new set of Ford 24# injectors to swap in, and I'm having a couple issues. The injectors will not clip to the injector clips. The injectors have 2 notches machined into them, 1 that goes all the way around, and another that is just on opposite sides. The clip will clip over the full circle notch, but the injector does not seat itself all the way in. Are there any type of aftermarket clips for this swap, what have you guys done?
 

·
Registered
Joined
·
603 Posts
have you hooked up a laptop to the diagnostic port to see what's going on with it? It could be any of several dozen items.....Opti gone bad, bad gas, knock sensor, jumped time, etc. If it sat for a few years, you might have moisture that gathered in the opti, which can ruin it. What year LT1 is it?

Also, did you purge the lines before you installed the new injectors?
 

·
Registered
Joined
·
215 Posts
Discussion Starter #5
The motor ran on its own less than 3 months ago. I dont have any of the software to hook up to a laptop. The motor has a CPS sensor, so I believe it is a 96.
 

·
Registered
Joined
·
66 Posts
Do you hear the FP prime?
Is the MAF hooked up, and getting 12v on the pink?
CPS hooked up?
Opti harness not curroded and plugged in correctly (not but one way).
Assume the starter is turning over the motor but no fire?
Are the plugs firing? tested a plug wire to see if there is spark?
 

·
Registered
Joined
·
215 Posts
Discussion Starter #7
The CPS sensor is not used, it was programmed out of the computer. It ran before without it. No MAF, speed density. Yes. plugs are firing.
 

·
Registered
Joined
·
66 Posts
The CPS sensor is not used, it was programmed out of the computer. It ran before without it. No MAF, speed density. Yes. plugs are firing.
Still have some unanswered questions:
Do you hear the FP prime?
Opti harness not curroded and plugged in correctly (not but one way).
Assume the starter is turning over the motor but no fire?
 

·
Registered
Joined
·
19,458 Posts
You can still get fuel pressure at the valve and still have air in the rail. Make sure you have bled all air out of the rail and try again.
 
1 - 11 of 11 Posts
Top