Pirate 4x4 banner

1 - 3 of 3 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter #1
Hey guys. I have this problem (well alot of them:p). But this one in particular is really bothering me. And would like to figure it out. Like the title says my gauge cluster is acting wacky. Just to make it easier/diagnose these are what each of the gauges are doing:

Engine Temp: Doesn't work 99% of the time but once in a great while it will come on for a short while
Fuel Gauge: Always reads full; awhile ago it used to read fine down to 1/4...
Clock: I can only remember this working when i first got the jeep, ever since it just doesn't work.
Oil Pressure: This seems inaccurate, only because it moves around even while not touching the gas. It will go from 40-60 just at idle.
Voltage: This is the only gauge I really trust. It seems to work as normal.

I have tried testing certain things, but i really don't know where to start or what to test to make this easier to figure out.

The following things I have tried:
I test the plug for the gauges with the following results:
Pin #1-Purple-Not Sure
2-White/Black (2wires)- Power
3-Black-Ground
4-Lt Brown/Black-Not Sure
5-White/Black-Power
6-Lt Blue/Green-Ground
7-Pink-Not Sure
8-NONE
9-NONE
10-Orange/Black-Ground
11-NONE
12-Orange/Black-Ground
Those where all tested with a circuit tester and test light...

Also I checked out the plug going to the temperature sensor, it wasn't getting power, but had a ground.

Also I tested the grounds on the engine and for the fuse box in the engine compartment. Good.
I tested them by attaching the power end to the battery and touch the grounds with the tip to see if they light up. Is that the correct way of testing?

Any help would be greatly appreciated
PS: I probally should have added that its 91' 4.0L YJ... :p
 

·
Registered
Joined
·
82 Posts
I had problems with this myself. 4 of the 5 on mine didnt work. I took apart the dash cleaned all the 13 years old dust and grime. took me 15 min. I took off the 6 or 8 screws holding the plastic dash cover on. then the 3 or so holding the guages to the dash. The wire harness on mine pluged into a peice of flat plastic with flat wires in it(like a prefab wire harness that came off a roll). I washed it all of put it back together and all my gauges worked. Now i do it once every season to get all of the dust and dirt out of it. Make sure to take all 5 of the gauges off of the cover they are in. they are held on buy the little center nut in the rear. they might take some slight force to remove because of crust build up. Also take the few dash bulbs out to clean that to while your at it. A few friends i wheel with had the same problem with the same fix.
 

·
Registered
Joined
·
506 Posts
Also the problem with the gas gauge is that the sending unit in the tank might be stuck too. Mine is the same way in my 87 YJ. The gas gauge is always pegged at too full and its because the sending unit is stuck in the full position in the tank.

Thanks for the info though on cleaning them. I might have to try that because I think that my voltage gauge is broken or I have some problems with my wiring, because depending on what I have turned on and if I have my foot on the gas or not, it is pegged all the way to the left.
 
1 - 3 of 3 Posts
Top