Pirate 4x4 banner

1 - 18 of 18 Posts

·
Registered
Joined
·
2,362 Posts
badass....good lookin' rig :D
 

·
Registered
Joined
·
747 Posts
:smokin: Nice rig man. must.....not.....drool. Im insanely jelous
 

·
Registered
Joined
·
701 Posts
Discussion Starter #5
it was hard for me too. I am waiting for the other 3 camras to get down loaded, they got many cool shots of my ZUZU..
 

·
Registered
Joined
·
747 Posts
Where are you? did you do the axle swap yourself? I'm in the process of trying to procure a lt1 and 4l60e out of a 96 camaro and maybe a set of full width axles:smokin:
 

·
Registered
Joined
·
701 Posts
Discussion Starter #8 (Edited)
Where are you? did you do the axle swap yourself? I'm in the process of trying to procure a lt1 and 4l60e out of a 96 camaro and maybe a set of full width axles:smokin:
I am in Sac. off the 80, No I didn't do the swap, but from what I had to fix it was pretty damn close to doing the swap myself. It would be just same as a YOTA swap. I had my hand in my buddy's SAS it went just the same as what I have done with my ZUZU.

I have just a 3.2 stock with 4l60e behind it. nothing special.

Getting an LT1 in a Rodeo would be cool but over kill, a basic 4.3 would swap strait over.
 

·
Registered
Joined
·
747 Posts
The appeal of the lt1 was that I could get the whole set up for 1200 bucks, and they are super fuel efficient. But it doesnt look like thats gonna happen now..... getting laid off sucks. I still need to do something though Im at 160,000 miles and she just blew her second set of headgaskets:( and I hate the mua 5 speed. Is that a late 70s Waggy front axle you got in there?
 

·
Registered
Joined
·
701 Posts
Discussion Starter #10 (Edited)
That sucks about getting laid off, its allways better just to get laid rather than off! Yes its from a 73 waggy. What was the tell tell sign of her blowing head gaskets, I have been running her she gets hot at 70 on flat land, on boy she fawking hates up hill, then she cools right down, still have all full fluid levels
 

·
Registered
Joined
·
747 Posts
Tell tale sign for me was no coolant and a pegged temp gauge:shaking: Now it overheats on the freeway. I never thought about a 4.3, just thought I'd go for the big boy right off the bat you know? Oh, what kind of gas milage do you get, im getting about 13 with stock drivetrain and 31's.
 

·
Registered
Joined
·
701 Posts
Discussion Starter #12
SHe has coolant I have replace hoses, themo stat, fanclutch and she still gets on the hot side ( the wrong kind of of hot side)

I got about 19-22 with 35's and 4.88's seems to be a good combo, I also have a auto trans that seems the key, my sis n law has a 5sp she is only hittin 15-18 with hers Y I don't know
 

·
Registered
Joined
·
747 Posts
I'm thinking my waterpump may have been a problem for me, But I have no desire to replace it. Sometimes I wonder what the hell Isuzu engineers were thinking when they designed these things.
 

·
Registered
Joined
·
701 Posts
Discussion Starter #14
Ya no kidding, I think that is next on my list, I just had evrything in the front of the motor done last year, it started with the water pump, went from $200 to $1200. I has broke my foot 2wks before it went out, I had no choice but to take it to a shop, CRAP I'll never do that again.
 

·
Registered
Joined
·
747 Posts
upon closer inspection my radiator may be crapped up to, sweet. Im tellin you its all about the small block chevy:D
 

·
Registered
Joined
·
211 Posts
Looks like fun. I think I need to make a trip out there one of these years. I gotta finish hooking up the dana 60 and 14 bolt for now. Almost done.
Troy
 

·
Registered
Joined
·
701 Posts
Discussion Starter #18
It has been freaking awesome, here are some shots from saturday, I put the D44 under some strain in the shot with the drivers tire, the p-side was stuffend rubbing fender,I wish I got a shot of that.



 
1 - 18 of 18 Posts
Top