Pirate 4x4 banner
1 - 2 of 2 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter · #1 ·
okay first off my yj has a strait 6 in it with the crappy ass carter carb on it. Anyway I have already bought a motorcraft 2100 just havent received it yet but had a question before I go any further. Okay I put that idle kit in my carter and it helped out wonders, so I went down the road went mudding a little bit and on the way home its started back firing and missing and shutting off on my, so I limped it home took the carb back apart and one of the idleing tubes was clogging up with some black stuff, so I cleaned it again put it all back together ran great went back down the road to play alittle and then on the way home same thing again. Is this just carb related or do I have other issues I need to look at?? Thankls.
Also is there a write up somewhere for the motorcraft 2100 install? and rebuilding it?
 

·
Registered
Joined
·
2,146 Posts
yeah the idle pickup tubes on mine would get clogged and idles like shit, or better yet didn't idle at all. i would take the carb apart to get to the idle tubes (not too hard to do in a few minutes with practice) and blow-out the tubes with compressor.............good to go for another 6 months maybe, depending on dust conditions etc.

so your prob sounds typical on the carter carb attached to the 4.2.

my best solution to the whole mess, along with massive stalling on verticals was:

FUEL INJECTION

dropped in a 4.0 out of a 91 and good to go. you will be so happy when you finally ditch the carb:flipoff2:
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top