Pirate 4x4 banner
1 - 6 of 6 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
I just bought another toyota and I need some help. I have never owned anything older that a 93. On the 82 that I bought, the catalytic converter had been removed (No emissions testing in Indiana). Right where the calytic converter was there is a pencil like probe tied to the frame. Someone told me that it was a thermosensor. What does this thing do? My truck lobes bad at idle. Also the old owner Said that the engine was out of another truck and I was wondering what year it is. The numbers on the block read 1535385. Does anyone have any information about the year of the block or where i can find some? It is a 22R. If that thermo sensor makes my truck run bad what can I do to fix it? I wasn't going to buy the truck, but I paid 500 Bucks for it. Had brand new 30x11.50x15 on eagle 054 15x10 wheels and detroit locked in the rear. It runs good above idle. Sorry for the real long post but just had some questions. <IMG SRC="smilies/skull.gif" border="0"> <IMG SRC="smilies/skull.gif" border="0"> <IMG SRC="smilies/skull.gif" border="0"> <IMG SRC="smilies/nuke.gif" border="0">
 

·
Registered
Joined
·
3,010 Posts
<IMG SRC="smilies/thefinger.gif" border="0"> welcome newbie <IMG SRC="smilies/thefinger.gif" border="0">

the good ol pirate salute! <IMG SRC="smilies/skull.gif" border="0">

it kinda sounds like they stuck your 02 sensor there. how many wires and give us some more information on it. do you have any idea what year its off of? more info and i'd have a better idea! <IMG SRC="smilies/biggrin.gif" border="0">
 

·
Registered
Joined
·
692 Posts
try disconecting it. My 83 has it. I don't have it hooked up. Cat is not set up for it. mine runs fine. Conector is under drive seat. All that it dose is turns off your valve that puts O2 in the exhaust so the cat can burn the bad stuff. It turns off the valve if the cat gets to hot. So it should not affect the way the truck runs. I think you have another problem. My truck had a leak at the intake manifold causing the same problem.
Steve
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #4 ·
Thanks guys <IMG SRC="smilies/biggrin.gif" border="0">
 

·
Registered
Joined
·
55 Posts
If it is what it sounds like to me it is a thermosensor and not an o2 sensor...it can be put into a universal cat and as far as it's function,I have no clue but when I had a bad cat it made no difference.
 

·
Registered
Joined
·
1,050 Posts
Ok time for help in the other dept. Get the truck running and warm. Spray carb cleaner all around the outside of the carb. Listen for the idle to increse or drop. If not turn the two screws on the pass side like so. Turn the most forward one (twards grill if you are leaning over the pass fender) about !revolution in. Thats your idle mixture. In less gas / out more. The one closer to the firewall is the main idle. Maybee try it in about 1/4 to a1/2 revolution.
BTW 500$ can't be beaten.
 
1 - 6 of 6 Posts
Top