Pirate 4x4 banner
1 - 5 of 5 Posts

· Registered
Joined
·
489 Posts
Discussion Starter · #1 ·
I stayed up Way to late on day last week and put my new springs , shackles, and bushings on. Post new spring I had bump steer and nothing else going on that was weird. After the list (SOA on RE packs) I get a odd wobble (visible at the wheel/tire) when the driver side tire hits a abrupt bump.. I have to slow down in order for it to recover. It will only do this when you lead with the driver side tire, so it hits the bump 1st.

New parts:

Springs
Bushings? everywhere except the upper frame mounts.. I inspected the rubber ones and they were in great shape.
Shackles?.
Everything connected with Grade 8?s and stovers
Ubolts ARE TIGHT

I did do this after I took a hard look at the install?.. I mismatched a bushing ?. PM me for a photo



And I think it's on the lower frame / drivers side? Could this be the culprit?
 

· Registered
Joined
·
489 Posts
Discussion Starter · #3 ·
Yep still on the front... But heres what I did.

REMOVED stock YJ packs set up SOA .. removed some funky 1.25" lift shackle

INSTALLED R.E. 1.5" springs on new 1/2 " shackles

meaning I netting a 1/2 lift over the old set up.......

I think I have a wrong sixe diameter bushing in the fixed frame loaction on the drivers side... and ONLTY the drivers side whell flops around... could this be the issue ?
 

· Registered
Joined
·
489 Posts
Discussion Starter · #5 ·
all shackles and fixed mounts are TIGHT. Ubolts are TIGHT... the only thing I see if that One undersize half bushing in the fixed frame mount forth laef spring ...could the problem be that ????? seem like it takes a good sized a bump to set it a wobbling....
 

· Registered
Joined
·
489 Posts
Discussion Starter · #9 ·
geberhard said:
what size RE springs?? 1.5 or 4.5"? Just checking... could be your caster? Also, same tires and wheels as before?

also measure centerpin location on the axle to centerpin location on teh axle (each side). If you went SOA and your perches are off, you could have the axle slightly sideways. I.e. if your perch hole is big, and one centerpin i to the front, other to the back, could be angling your axle. Are ytou having a pull to any side?

Same perches that I've been SOA on for over 3 years.. not a issue I used the R.E. 1.5" 6 leaf springs on all 4 corners... took off some 1 1/4 " lift shackles made some 1/2" lift shackes so basically I netted about 3/4" of overall lift (old set up<stock YJ packs>. Spring perches were set up to the STOCK camber... nothing really changed.... I did measure it via a angle finder placed on top of hte ball joint and it came to about 6 degrees..... should be reasonable.

Jeff
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top