Pirate 4x4 banner

1 - 11 of 11 Posts

·
Registered
Joined
·
122 Posts
Discussion Starter #1
ok, wife has the camera, so I'm using an old picture.
What is the piece directly above the water pump called, and why would it start leaking radiator fluid, which I think it's what it is? you can just see the bottom of it in this picture. I just replaced the water pump and it's fine, but now I got green stuff oozing out of this thing? Is that big trouble? Ignore the arrows, it's from an old post.

 

·
Registered
Joined
·
4,312 Posts
thermostat housing? is this what you mean? it holds .......... the thermostat which has coolent running thru it. is it leaking from one of the treaded plugs(which were for emmisions) What ever it is thats leaking I would fix it.
 

·
Registered
Joined
·
122 Posts
Discussion Starter #3
yes, i want to fix it, but first i want to know what i'm getting into. i can do the work, but i'm learning as i go.
 

·
Registered
Joined
·
4,312 Posts
proffitt'scruisers said:
Not a dumb question

bypass vacume switching valve. bvsv
add, it's an emmision thingy....your cruiser has been desmoged so it's not used, they are normaly pluged off, I can't tell if yours are or not. You could remove it and add a temp guage, or just leave it or put a solid plug in. If thats leaking remove it, and put some Teflon tape on the treads and reinstall.

if the t-sate housing is leaking, get a new lower gasket, t-stat(if you havn't replaced yours already) and upper rubber gasket.

Is your motor a 2F? (must be if it has the ports on the t-sate housing) wondering why your fan not running a fan clutch, it looks to be mounted solid(using a spacer) to the water pump for some reason. If it were me I would replace it with a fan clutch as it will free up some power.

John H
 

·
Registered
Joined
·
3,527 Posts
So what year water pump did you end up running? The reason the new pump from me didn't work is because your fan and the spacer are non-OEM... :eek:
 

·
Registered
Joined
·
122 Posts
Discussion Starter #9
I just ran a '78 from autozone. kurt, you're gonna have to explain to me what and how to do the fan clutch thing. I'm all for it if it will free up some power. I think I mentioned it earlier, but I'm new to doing all the work on this thing. You guys explain it to me, and if it'll make a difference I'll try to cough up the money for the parts then do it. PM or call me Kurt so I can figure out whether or not I need to do this.
Also, I still want that top, and I already ordered the channel.
 

·
Registered
Joined
·
916 Posts
when you pull out the bvsv be careful not to be to rough I have seen and heard that if it just starts leaking by itself that the cast aluminium has been eating away and that is not good can be fixed but if you are rough with it, it can make it worse
 

·
Registered
Joined
·
10,444 Posts
I replaced mine with a return line for cooling the turbo..

:flipoff2:


Even if it is leaking bad. JBweld can fix it.
Fan clutches were facotry on most 2F's. Put the stick fan on and the clutch comes with it. I have never liked the FLex fans...
When you hit water with them it is nasty....
 
1 - 11 of 11 Posts
Top