Pirate 4x4 banner

1 - 11 of 11 Posts

·
Registered
Joined
·
1,071 Posts
Discussion Starter #1 (Edited)
well, i get out of work early to get my truck smogged and ready for Baja this weekend. I decide to do a good deed for the smog guy and clean the engine a little. Sprayed on my favorie gunk engine foam, let soak 5 mins, sprayed with hose (done this same procedure on my rigs) and now the thing wont start at all! Turns and Turns and Turns (seems faster then usual), but no luck! Doesnt even sound like it wants to start (sounds like no fuel). I Checked the fuses and all are ok

Any ideas? I am kinda stuck, it is sitting 1/2 way into the street! :D

Figures, the FSM should be here tomorrow! ARGGG
 

·
Registered
Joined
·
2,289 Posts
take the cap off the distributor and wipe it clean. Might spray WD-40 in there. If that was the fix,its cause you got water in the distributor and probably needs a new cap and rotor, wires would be good too.

-Dustin
 

·
Registered
Joined
·
3,970 Posts
Every time I've done this to a Ford product I've had the same results. Chevy, Dodge, old L/C, no problem. The distributor fix never worked, walked away, the next day started no problem! Moisture somewhere is the obvious answer but with electronic stuff, it's all black science to me.
 

·
Registered
Joined
·
1,071 Posts
Discussion Starter #6
Got It!

Thanks guys, i pulled this dist and dryed it and whammo

Thanks

Lets hope it passes smog!
 

·
Premium Member
Joined
·
8,609 Posts
Rat70FJ said:
Every time I've done this to a Ford product I've had the same results. Chevy, Dodge, old L/C, no problem. The distributor fix never worked, walked away, the next day started no problem! Moisture somewhere is the obvious answer but with electronic stuff, it's all black science to me.

Every time I have had the problem the distrib fix worked for me...Funny

I bet you anything Kevin its the dist being wet in your situation. Have fun getting to the screw on the bottom :D you need a super stubby screw driver and tiny hands
 

·
Registered
Joined
·
2,289 Posts
Kent- thats cause youre just blowing hot air into it- creating more steam. :flipoff2: :laughing:

-Dustin
 
1 - 11 of 11 Posts
Top