Pirate 4x4 banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,170 Posts
Discussion Starter #1
Last night the 87rrc, stalled a couple of times, which it has done in a long time.
First after a smile on road climb, I went on to the slopes of the resort, dropped into neutral to shift the transfer case.....and it stalls. No sputter or anything, just dies.
Go halfway up the mountain and back(looking for a coworkers radio that he lost). Going downhill onto the pavement, shift to neutral to put in high range and it stalls again. :shaking:
Drive a mile more uphill and down...at an intersection...downhill. At the stop, it stalls. I parked the truck for awhile. Later when I left, downhill more, at the intersection at the bottom of the hill, it stalls again.
No issues on this mornings drive.
Idle is steady.
Last thing I did under the hood was rebuild the alternator.

Possible I botched a connection? maybe messed up a vacuum line?

Earlier in the rangies life with me, it would stall downhill, while in gear in low range....but the idle vary greatly. Replacing a broken vacuum line fixed that problem.
 

·
Registered
Joined
·
440 Posts
I had a simular problem, only mine happend when i turned. It was a bad connection of the cable between the distributor and the bobine (is that an english word??)

I'll add some pic's to clarify:

old cable
old cable 2
bobine
distributor

Maybe that's the problem. The symptoms are the same.. It just stalls without any warning.
 

·
Registered
Joined
·
1,170 Posts
Discussion Starter #3
Thanks for the reply...

Forgive my ignorance, what is a bobine?....do you mean the coil?
 
1 - 5 of 5 Posts
Top