Pirate 4x4 banner
1 - 4 of 4 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
I just swapped in an EFI. I hooked up the fuel pump.....turned the key...no clicky!! Hmmm..always wanted to do the clicky fix...assembled the relay and wires...I had forgotten to attach the lead for the starter!! Dooohhhh

Hooked up the clicky fix and....vroooom!! After six months, my sammie is alive again. Now I have a huge puddle of oil on the ground!! Never leaked oil before. It looks like it's coming from the front main. I will replace that, the timing belt and oil pan gasket. For pans, do most of you buy gaskets, or make them? I don"t have the air cleaner hooked up and oil was spraying out of the breather pipe off of the cover. My pcv is brand new but I'm guessing there needs to be a vacuum for it to work properly. I'm waiting on the mega flow filter from Rocky Road. Does anyone else use it? How do you like it? Does it have a vacuum hook up for the pvc? Any other guesses on what would be causing the leak?

One more item, I am still in need of a windshield frame assembly with wipers and glass. I only have the driver's side wiper and the glass is starred in several places. Itlived behind a motorhome before I got it. When the frame broke around the wiper, they cut it out and put a plastic cover over it.

Thanks again everyone.
 

·
Registered
Joined
·
1,106 Posts
Just use a bead of RTV to seal the pan. You can buy a gasket for them but they never came from the factory with a gasket.

For the leak, how long did the rig sit? Some seals could have dried up if it sat too long. Also make sure you fuel pump block off plate has a good seal.
 

·
Registered
Joined
·
3,061 Posts
Dam thats alot of questions:D
Oil leaks happen......no real science to it just replce the seals gaskets whatever....Im not sure why its happening but there shouldnt be oil flying out of the valve cover:confused:
 

·
Registered
Joined
·
1,874 Posts
My engine generated a gusher of a leak from the lower front one day. Why I don't know. It would leak as much as a quart before the engine warmed up. Once the engine warmed up, it would stop completely. Turned out to be the oil pump gasket.
 
1 - 4 of 4 Posts
Top