Pirate 4x4 banner

1 - 14 of 14 Posts

·
Registered
Joined
·
8,153 Posts
Discussion Starter #1
Does that silly stock one do any good?

I've noticed just about every rig I've seen a picture of has gotten rid of it.....

Has anyone really boiled the fuild??
 

·
Wicked Raciest !
Joined
·
17,734 Posts
Kyron said:
Has anyone really boiled the fuild??
I have, that is why I got a Tranny off an 80's Aerostar and put it into the system. I have the cooler, filter, and extended the reservoir. System now holds about three quarts. :grinpimp:
 

·
Registered
Joined
·
1,501 Posts
Any cooling is better than none. The stock unit is fine for street driving. I blew out my sector shaft adjuster seal on the Gatekeeper with a stocker. A junkyard trans cooler for $5.00 fixed that.
 

·
Registered
Joined
·
799 Posts
I have a tranny cooler in mine just because and have never had boiling over issues. I am working on another project and the rig has a tranny cooler built into the radiator, I was wondering would this work sufficiently to cool the PS fluid or would it actually warm it up at times?
 

·
Registered
Joined
·
12,646 Posts
I have overheated mine plenty til i got a cooler, I just started haveing the problem again with the 37's aired down to 10 psi, and in 4wd lo. My pump was shot, and I am sticking a ifs box on finally. 7 yrs with push pull is all i can take. :p
 

·
Registered
Joined
·
3,591 Posts
OOP'S said:
I have, that is why I got a Tranny off an 80's Aerostar and put it into the system. I have the cooler, filter, and extended the reservoir. System now holds about three quarts. :grinpimp:
Opps,

Do you got a pic of you setup? Did the aerostar have the filter or is that an addtion you made above and beyond the junk yard stuff?
 

·
Wicked Raciest !
Joined
·
17,734 Posts
vikingsven said:
Opps,

Do you got a pic of you setup? Did the aerostar have the filter or is that an addtion you made above and beyond the junk yard stuff?
Modified reservoir with a piece of exhaust tubing



Oil filter relocation kit from Summit



AeroStar Cooler



RedNeck Ram

 

·
Wicked Raciest !
Joined
·
17,734 Posts
vikingsven said:
Very nice!
So it is acceptable to use a regular oil filter as the PS filter?

6" or 8" Ram?
I talked to WelderBilt about that and he said it would be ok, a regular Hyd. filter is a bit smaller in microns, someday I may try to find one that willfit the adapter. I think it is a six inch, do not know for sure it came with the kit. :grinpimp:
 

·
Registered
Joined
·
3,169 Posts
I run hydro assist without a cooler and it works fine, but I run a GM pump.
Maybe the greater fluid volume keeps the fluid cooler.
Jay
 

·
Change is good.
Joined
·
35,183 Posts


I run the small Hayden Transmission cooler from from Ghetto Zone , and it works fine. I didn't really have a problem before, but the PO had taken off the loop :confused: , and the hose was kinda' kinked because of it.

Doc
 
1 - 14 of 14 Posts
Top