Pirate 4x4 banner
1 - 2 of 2 Posts

·
Registered
Joined
·
426 Posts
Discussion Starter · #1 · (Edited)
I just spent an hour searching, and cant find any information on my problem so here it goes.

I have a 91 chevy 1500 with a 60 front, high crossover steering, and using the stock IFS steering box (3 bolt).

I have never been able to turn well, so I started looking into the problem. I put the front axle on jackstands and cranked the wheel lock to lock both directions. From center its 2.75 turns each way to lock but the tires do not turn until they hit the steering stops. Nothing is binding or hitting anything else. It looks like the tires only turn 60% of how far they could if they went to the steering stops. I have been wheeling it for years and everything works fine except that I can't turn sharply.

I just got my hydro assist parts and I am pulling the box to tap it and the pump to upgrade it but I want to fix the turning problem first.

The pitman arm is 7" center to center, which seems standard. I am running the sky dana 60 high steer arms.

My drag link was angled up a bit, but I am rotating the box down a bit so that it will be parallel with the axle and tie rod while I am at it but I am positive that wont get me to hitting steering stops.

So is the problem my box? do I need a longer pitman arm? Something else?
 

·
Registered
Joined
·
426 Posts
Discussion Starter · #4 ·
keep in mind that the more angle you turn, the more likely you are to break your u-joints. I think it is about 30° or so of turning for most ujoints. Longfields CV's only get 45° of turning
Yea I understand but i may be getting 15-20 degrees at most right now...
 
1 - 2 of 2 Posts
Top