Pirate 4x4 banner

1 - 5 of 5 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter #1
Where can I find info/writeups on mods/upgrades on the Qtrac? Looks like the Willys is taking alot longer than I hoped. So I decided to put it on the back shelf and put the tub on the cj7 and get it going. That way atleast I'll have something to play with while I'm doing the flatty. Problem is it has a Qtrac and I know nothing about them. I do have a th400/d20 from an old Waggy but was kind of worried the 2:1 low with the 3:54 axles might suck. Plus I've heard the factory adapters are real weak.

Thanks
Keith
 

·
Registered
Joined
·
4,428 Posts
If you plan to use your QuadraTrac for long, I would recommend buying a new chain, replacing the seals, and filling it with fresh QT-lube. It takes special stuff, not just ATF; unless someone did the milemarker part-time conversion already.

Rebuild info and fluid capacity is in the technical service manual. Someone might have done a writeup on rebuilding one on the IFSJA .

Parts are sold through 4wd Hardware. I bought my chain and lube from Specialty Parts.

[ 11-01-2001: Message edited by: John J ]
 

·
Registered
Joined
·
1,036 Posts
In my opinion I would just throw the 20 in and junk the qtrack. They are a good design i theory but they just don't work very well. go with the 20!
 

·
Registered
Joined
·
4,036 Posts
Originally posted by Bgcj5:
<STRONG>In my opinion I would just throw the 20 in and junk the qtrack. They are a good design i theory but they just don't work very well. go with the 20!</STRONG>
you can't just throw a 20 on, lookd for adapters to bolt ANY other transfer case top the back of a TH400 with quadratrac and couldnt find anything <IMG SRC="smilies/smile.gif" border="0">
 

·
Registered
Joined
·
22 Posts
Quote: I do have a th400/d20 from an old Waggy...


You said you had a 400/20 combo... what's the problem? <IMG SRC="smilies/thefinger.gif" border="0">

I'd say get rid of the quadrajunk and get the th400 and d20 in at the same time. I've just done this, using the 400/20 and it bolted in just fine... now I just have to finish the SOA...
 
1 - 5 of 5 Posts
Top