Pirate 4x4 banner

1 - 4 of 4 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
I have a 96 XJ. I have been having some random starting issues for a while but they are so come and go I have not done anything about it. It only happens when its cold, below 40* (but its still very random). Ill crank it over and it will start but as soon as i let the key off it will choke for a second then high idle then drop to about 900k or it will choke and die. When it dies I can turn the key and all it will do is crank and wont turn over, I have to basically put the gas to the floor so it will start. From there it is fine, no idle issues no high or really low idle, the only thing is the oil pressure just jumps back and forth between the 40 and the 60. The only other issue after it starts is, if I very gently put the gas there is no hesitation, but if I put the gas on like I normally would it will choke, drop the rpms to 500 then catch and I am off and running. There are zero driving issues other than that. I was told I should clean the IAC and that solved his problem.

Oh I have intake, bosch plugs (like year and a half old), and autozone brand wires that are a year and a half old. The distributor, cap, rotor are all stock 1996.

EDIT: I pulled the IAC motor, the IAC housing and it still hard starts and idles around 1200k in park and neutral. I did find the gasket to be toast on the housing.
 

·
Registered
Joined
·
297 Posts
fuel system
pump
filter
other crap..
check em
 

·
Registered
Joined
·
93 Posts
Fuel Injected, might be your injectors. My 88' XJ has a similar problem. It would stumble when you gave it gas. I run injector cleaner in the gas continually and it helps.
 
1 - 4 of 4 Posts
Top