Pirate 4x4 banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,214 Posts
Discussion Starter #1
went to put the drag link on today and I had to take it off a couple of times to test fit it(having to file material out of arm:mad <IMG SRC="smilies/smile.gif" border="0"> and while trying to tighten down castle nut the bolt that it tightens to just spins?WTF!!! Is it fawked??
 

·
Wicked Raciest !
Joined
·
17,734 Posts
Check the threads on the tie rod end, If they are messed up a bit use a 3-cornor file and straiten them up, if they are messed up in the nut, you may have to get a new nut (I would run a tap through it only because I have a full metric tap & die set). Then when you put it in the hole, smack it with a rubber, lead, or dead blow hammer to seat it in the taper. Hopefully that will be enough to be able to tighten it down.
 

·
Registered
Joined
·
1,214 Posts
Discussion Starter #3
thats just it...I have to file the hole on the arm just to get the bolt on the TRE to fit through the steering arm and I have to see if it fits every once in a while to make sure I dont take off too much...try to tighten the castle nut down but the bolt just spinns with the ratchet
 

·
Registered
Joined
·
115 Posts
I am assuming(oh no) that you are tightening by hand. What happens alot of the time is the tie rod portion spins in its socket(the main body) and will not get the tapered seat to hold. Using air is the easiest way around the prob, but if you have a pickle fork you can pry between the tie rod and the arm while tightening and you can get some torque on the nut. Hope it helps..
 
1 - 4 of 4 Posts
Top