Pirate 4x4 banner
1 - 8 of 8 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
My 1988 (early) Sammi with the 1.3 engine has been leaking oil from the rear of the valve cover(near the distributor)... When I run my fingers along that particular part of the gasket area, I get motor oil on my fingers... A few months ago, I adjusted the valves... Before I installed the NEW valve cover gasket, I made sure to remove all traces of the old gasket on both the valve cover and
it's mating area on engine. Everything was absolutely smooth and clean. I installed the new valve cover gasket and made sure it did not shift while torquing to factory specs...

Now it's leaking (not a flood... but a definite leak). Should I install two gaskets next time??... Is there a fatter gasket available?? The four top valve cover bolts are torqued to factory specs... Is there anyway to make 'em tighter?? The valve cover
gasket is definitely not leaking anywhere else... <IMG SRC="smilies/usa.gif" border="0">
 

·
Registered
Joined
·
705 Posts
It sounds like you did the valve cover right, try checking the distributor o-ring. I know mine is leaking and its right at the rear of the valve cover. This is common on the 1.3L. <IMG SRC="smilies/rolleyes.gif" border="0">
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
Thanx... I'm gonna replace my new cork valve cover gasket with a rubber one AND replace the Distributor 0-ring at the same time.. <IMG SRC="smilies/bounce2.gif" border="0">
 

·
Registered
Joined
·
7 Posts
My fuel pump gasket was leaking and i thought it was my valvle cover at first, but i just might be a dumb ass
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #7 ·
Thanx to all for help with answers... I am planning to replace my new cork valve cover gasket with a new rubber valve cover gasket... sealed with Copper Coat... I will also replace my distributor O-ring...

I replaced my fuel pump two years ago when I noticed it leaking engine oil...
Lee <IMG SRC="smilies/usa.gif" border="0">
 

·
Registered
Joined
·
1,121 Posts
you might get away with alittle sealer on the old o-ring i did even though i had a new one <IMG SRC="smilies/biggrin.gif" border="0">
 
1 - 8 of 8 Posts
Top