Pirate 4x4 banner

1 - 15 of 15 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #1
I took my rover out this and noticed it's running like crap and has no power. I would have to put it in 1st low just to get going and even then I had to baby it to keep from stalling. it also seemed to be smoking more than usual. it was more of a dark smoke like you would expect from a diesel.
any help would be appreciated
 

Attachments

·
Registered
Joined
·
257 Posts
Bad / Ethanol gas could have gummed up the carb, how does the bowl look. Does the truck have a pertronix in it yet, which carb are you running Solex Zenith Rodchester, does it still have a 2.25 in it. need more info. I would start by spraying down the carb with deep creep / carb cleaner if you can keep it running, see if that helps at all.
 

·
Registered
Joined
·
65 Posts
Discussion Starter #5 (Edited)
I'm running a zenith. I did try the carb cleaner with no luck.
and hell it won't even fire up today:mad3::mad3:
edit: yes it is the 2.25, no ethanol gas
 

·
I build stuff
Joined
·
24,247 Posts
air-fuel-spark-compression

Remove the intake from the carb to eliminate that being the issue.
Is the glass bowl full of fuel? What does it look like.
Remove and check condition of plug, are they wet with fuel, burnt, gap set
Condition of points, points gap set, do the screw driver trick to check for spark out of the coil, and then all four plugs
Check compression on all four cylinders.
 

·
Registered
Joined
·
65 Posts
Discussion Starter #9
well checked the sediment bowl and it appears to have rust chips in it I also went to check the spark plugs but I broke my spark plug tool so it will have to wait until after the fourth
 

Attachments

·
I build stuff
Joined
·
24,247 Posts
well checked the sediment bowl and it appears to have rust chips in it I also went to check the spark plugs but I broke my spark plug tool so it will have to wait until after the fourth
The pickup tube in the fuel tank should have a screen over it.
Disconnect the input line from the fuel pump, pull the pickup out and blow out the line. Stick the pickup into a clean gas can, reconnect the line at the pump

Disconnect the line going to the carb at the carb. Use the priming lever and see if you get fuel out of the line.
 

·
Registered
Joined
·
65 Posts
Discussion Starter #12
ok I cleaned out the sediment bowl and confirmed my fuel pump works
then I tried to start it but nada
so I think it is either carb or spark plugs
and by the way I do have the electronic distributer
 

·
Registered
Joined
·
65 Posts
Discussion Starter #13
update checked compression every cylinder was right around 120 psi got new spark plugs and gapped them accordingly and you know what it fired right up haha its always the small things that get ya
 

·
Registered
Joined
·
65 Posts
Discussion Starter #15
just a little update if anybody is running a zenith carb and it random quits or won't start, crack up open your carb and check your o ring around the throat. I've had the worst luck with these o rings. the one from the rebuild kit split like the one in the picture. I went to Napa and got two generic o rings put the thicker one (in the picture)in there and it lasted about a month and a half of weekend driving. then today I noticed it was running rich and back firing. So I checked the o ring and sure enough it was split so I put the thinner o ring in and it seemed to work put after driving a little ways it quit on me. so I'm guessing since it thinner it stretched or exapanded and caused the carb to get out of whack
 

Attachments

1 - 15 of 15 Posts
Top