Pirate 4x4 banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
hey ive got a first gen 350 with hei, i replaced the factory intake manifold, carb and distributor with a edelbrock performer intake, holly 650 double pumper and a msd street fire distributor. i set the engine tdc at the top of the combustion stroke for no.1 took off the old intake carb and dist. put the new parts and seals on set new dist. at 5:30 tried to prime it by pouring a bit of gas down the carb, i got one blub then just dry cranking, i tried again with starter fluid but no go. tried again the next night got another blub then dry cranking, any ideas?
 

·
Registered
Joined
·
618 Posts
Move your distributor around while someone is cranking it for you. are you sure you aren't 180 off?
 

·
Registered
Joined
·
408 Posts
Move your distributor around while someone is cranking it for you. are you sure you aren't 180 off?
x2 i would bet its in your timing as well. did you mess with your carb before install or was it right out of the box and on to the engine. there could be adjustment issues there as well but without being there and seeing exactly what you have going on your just gonna need to check and recheck your setup and do a lil trail and error tell you run down the problem. start with the basics, spark, fuel n air mixture, timing, etc.... keep us updated and im sure we can get that sumbitch to run :flipoff2:

vacuum to dizzy is disconnected when ur cranking?
 

·
Registered
Joined
·
106 Posts
You could be off on timing, you sure its on compression stroke?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
well i figured it out, there was a air bubble in my fuel filter and i had the dist set way to late, i still need to fine tune every thing but i took it out for a test drive and it took off like a raped ape, i just have to find the idle screw and play with the choke, it dies as soon as i turn it off (manual choke)
 
1 - 5 of 5 Posts
Top