Pirate 4x4 banner

1 - 9 of 9 Posts

·
Registered
Joined
·
482 Posts
Discussion Starter #1
Tapped and installed new ram system. It works, but blows fluid back out the top of the PSpump cap when turning left hard. Any advice? It also wants to turn right better than left, so I assume this is part of the same issue.

Followed directions on this sight for drilling location, and I got it right. Air flowed through all passages.

Thanks
 

·
Registered
Joined
·
1,858 Posts
You've probably still got air in your system. I'd try to bleeding it some more. Search around on here and you'll find tons of threads with good info for bleeding ram assist systems.

Kevo
 

·
Registered
Joined
·
415 Posts
What is the rod size of the cylinder you used? If the rod is large, it will take less fluid volume to fill one side, and will also have less area on the piston, making it easier to turn one way than the other
 

·
Registered
Joined
·
1,093 Posts
You need a larger reservoir.
Why do you think all the aftermarket ram assist come with a second remote reservoir.

Like stated above single ended actuators have need more fluid to fill the non shaft side and less fluid to fill the side with the shaft. The shaft takes up volume.
Same reason why actuators can always push harder than they can pull.

So if you have no air and you are pushing fluid out get a larger reservoir or second reservoir and fill it when the shaft is all the way in the actuator (smallest volume)


Hope that helps
~Justin
 

·
Registered
Joined
·
482 Posts
Discussion Starter #9
Updated question:

I can turn lock to lock and the reservoir still has fluid in it. It did blow some out the top at first, but no longer does.

It wants to turn right better though. If I were to jack up the front, I think it would creep to full right. If im driving it makes a right hand turn. I assume this is the ram doing this. Its drivable, but annoying. I think all the air is our, but the fluid is "frothy".

Thanks Advice Please?
 
1 - 9 of 9 Posts
Top