Pirate 4x4 banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,408 Posts
Discussion Starter #1 (Edited)
I had the oil pump hole on the NP246 in a 99 Suburban. Got a new one from T Case Express. Having a very hard time getting it back in. Does anyone have any advice? What's the best way to angle it? Should I remove the transmission cross member? I'm about out of ideas and I've tried every "position". Heh heh.
 

·
Registered
Joined
·
8,379 Posts
Problem you are having is aligning the splines. If you can keep the t-case in gear and hold the rear splines solid while wiggling it on it will jamb in. OR pick a bolt hole with access and put a piece of threaded rod to help hold the case in place while doing the above.
 

·
blatant asshole
Joined
·
12,110 Posts
I always remove the cross members. Put it up the and roll the left side up and down til the spline drop. Then roll the studs into position.

Do the top stup first, it wont hurt anything and the rest will go easier.
 

·
Registered
Joined
·
1,408 Posts
Discussion Starter #4 (Edited)
I always remove the cross members. Put it up the and roll the left side up and down til the spline drop. Then roll the studs into position.

Do the top stup first, it wont hurt anything and the rest will go easier.

Yeah I ended up moving the cross member. Got her all plugged back up and now the tranny is grinding going to park. I just was checking t case function and the tranny has this nasty grind going to park now. --- might just be low on fluid. I'm gonna check all that before I get stabby with it.
 
1 - 4 of 4 Posts
Top