Pirate 4x4 banner

1 - 11 of 11 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
my '99 TJ 4.0 will turn over but not start. it's getting spark and gas and when I tried to pull the codes, I didn't see anything come up. when I try to start it, it turns over strong but will not even come close to starting however, as soon as I let go of the key, it sounds like it almost catches and wants to start.

I was going to change the CPS but the thing is like $140. I'd like to actually troubleshoot this and find the problem instead of throwing money at it. something else I was thinking is maybe throttle position sensor....? what are the steps I should take to properly troubleshoot? thanks.
 

·
Registered
Joined
·
281 Posts
try turning the ignition on then off like 3 times and on the 4th let it so just the accessories are on and a code might flash. Im not for certain if it will work but its worth a shot. (Don't turn it till the motor turns over just till the acc. come on)
 

·
Registered
Joined
·
14 Posts
Discussion Starter #8
correction...it LIVED again. now, after running fine for 2 weeks it broke down again. I figured the sensor was bad and bought another one. no go. any suggestions?
 

·
Registered
Joined
·
281 Posts
correction...it LIVED again. now, after running fine for 2 weeks it broke down again. I figured the sensor was bad and bought another one. no go. any suggestions?
So is it doing the same thing again.. What is it doing this time
 

·
Registered
Joined
·
14 Posts
Discussion Starter #10
exactly the same thing. turns over fine but won't start. maybe it's the voltage regulator....just a guess:(
 

·
Registered
Joined
·
1 Posts
I had a similar situation with my '99 TJ (4.0). I found out that there was a short in the wiring going to the fuel injectors, it kept messing with the ASD relay.
 
1 - 11 of 11 Posts
Top