Pirate 4x4 banner

1 - 9 of 9 Posts

·
Registered
Joined
·
394 Posts
Discussion Starter #1
Putting my hx35 back together, and as soon as you get the smallest bit of torque on the nut, the impellers bind up and you cannot spin the shaft. I checked everything is seated corrected..i dont see a problem, any ideas? Im sure its something small and silly I am looking over
 

·
Registered
Joined
·
394 Posts
Discussion Starter #3 (Edited)
which seals you mean exactly? on the hot side all I put on is that keeper ring, then slid the heat shield over, then slid the assembly into the bearing housing body. All teh snap rings seat in place so that is confusing me, because if the stack wasnt lining up right, then snap rings shouldnt have space to sit (i mean the big one that holds the oil slinger assembly)
 

·
Registered
Joined
·
273 Posts
Download the rebuild manual from Holset's website. Did you do a full rebuild? Did you check the shaft for runout?

Ed
 

·
Registered
Joined
·
394 Posts
Discussion Starter #5 (Edited)
Yes i have the rebuild manual. yes full rebuild, had the rotating assembly balanced and inspected.
My guess is something stillisnt seating right. You can stack it and spin it fine, but start to torque it and thats when the binding occurs.
 

·
Registered
Joined
·
185 Posts
which seals you mean exactly? on the hot side all I put on is that keeper ring, then slid the heat shield over, then slid the assembly into the bearing housing body. All teh snap rings seat in place so that is confusing me, because if the stack wasnt lining up right, then snap rings shouldnt have space to sit (i mean the big one that holds the oil slinger assembly)

The seal or piston ring that goes around te turbine shaft and slides into the CHRA. Make sure it's all the way in. If not it will bind.



Sent from AutoGuide.com App
 

·
Premium Member
Joined
·
3,887 Posts
You probably don't have the thrust bushing lined up properly.

The he,hy,hx35 and hx40 all use the same stuff. I have a 40 apart at home that I can take pics of when I get off work.
 

·
Registered
Joined
·
394 Posts
Discussion Starter #8
I have looked at the piston ring on turbine shaft, it does seem to sit all the way in and has a nice click when you push it in. I shall investigate the thrust bushing when I return home.
Thanks all/.
 

·
Registered
Joined
·
394 Posts
Discussion Starter #9
pulled from another site but this is how i set mine up as well:




OH! this is wher ei messed up i think. I beleive i put the upper thrust collar in backwards!
 
1 - 9 of 9 Posts
Top