Pirate 4x4 banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4,104 Posts
Discussion Starter · #1 ·
i have this 99 vortec in my jeep and it runs but not well. i have narrowed it down to the injectors for cyl. 1 and 8 are not firing/spraying. i have determined that the injector drivers are not working in the computer (it's new because i went with a 97 computer that did away with advance evap and vats systems). i have voltage to the injectors but the injector drivers in the vcm are not grounding the signals to those two injectors. my question is can i have this fixed on this computer or is it bad? i plan a trip in a week and a half and i'm not ready!!!! help!!!! evrything else seems to be working fine. it actually idles fairly smooth to only be running on 6 cylinders. anyway any help is appreciated.
 

·
Registered
Joined
·
3,169 Posts
ECMs are pretty darn reliable. Maybe you've already covered all this. I would double check your wiring and connectors if you haven't already done so. Make sure all the contacts are clean and try unplugging and replugging all the applicable connectors.
Jay
 

·
Registered
Joined
·
730 Posts
I am making an assumtion that you are running a 99 GEN 3(newV8), if you are running a 99 5.7(oldV8) then may be easier to have a dealer with a injector coil tester diagnose the injectors as they don't use a standard noid light to check.

fairly simple circut, I assume you have power to all the injector since they came of 1 or 2 fuses (depending on harness). DO you get a noid light to flash on those two inj circuts? if so is more likly high coil resistance in the injectors. if not check the circut for open, or short. if circut is good, then check power, grounds, and terminal tension and connection at PCM. IF all ok last thing is PCM.

HTH
 

·
Registered
Joined
·
18 Posts
buy a carb
 

·
Registered
Joined
·
4,104 Posts
Discussion Starter · #6 ·
Originally posted by cruiserrg:
<STRONG>I am making an assumtion that you are running a 99 GEN 3(newV8), if you are running a 99 5.7(oldV8) then may be easier to have a dealer with a injector coil tester diagnose the injectors as they don't use a standard noid light to check.

fairly simple circut, I assume you have power to all the injector since they came of 1 or 2 fuses (depending on harness). DO you get a noid light to flash on those two inj circuts? if so is more likly high coil resistance in the injectors. if not check the circut for open, or short. if circut is good, then check power, grounds, and terminal tension and connection at PCM. IF all ok last thing is PCM.

HTH</STRONG>
well i think i have it figured out. i just got a pinout from the 97 computer and it is a bit different. i was told that it should work and it will but i have to move a could of wires to make it match the 99 harness. yes it is the "old" vortec 350. anyway thanks for all the input.
 
1 - 6 of 6 Posts
Top