Pirate 4x4 banner
1 - 3 of 3 Posts

·
Registered
Joined
·
169 Posts
Discussion Starter · #1 ·
I posted here, because I think this is the best section onthe forum to use and after I did a search, but didn't find a real answer.

Yesterday, i was off roading and I was leading a group of 5 Jeeps. we came to cross a river , which I have crossed last year, but the water seems high, so I attached my Jeep to the guy behind me, got in the water and it was TOO high, water was covering my hood, so since the guys were trying to pull me out and my engine died on me right away, it took more like 1 1/2 hour to get me out. one winch pulling and 3 holding the winching Jeep.
I have a 2000 TJ, meaning I have no distributer, but the Jeep wouldn't start, starter was turning, battery is fine. so I removed my spark plugs and I found water in there, Turned the starter and water was pissing out the cylinders.

So what am planning to do is

1) suck all the water and dirt can be found in my cylnders with a shop-vac using a small hose and put it where my spark plugs go.
2) put new spark plugs.
3) Change my oil run the Jeep and wait for 20 minutes or so and drain the oil and put new oil and new oil filter.


What do you think? do you have another recomendations to do ?
 

·
Registered
Joined
·
169 Posts
Discussion Starter · #3 ·
Ok, here's the update:

I changed my spark plugs after I have sucked most of the water I was able to reach by a shop vac through 1/4 house attached to it, I left it an overnight with the heater block attached. When I got back next day it was all nice and warm, so I procedeed with installing the spark plugs and the rail, new air filter and charged the battery, then drain the oil as it looked like mayonesse in caramel, poured in the new oil with an engine flush and a new oil filter, I wanted to run the engine for 15 or 20 minutes and then drain it and put new good oil.

But when I come to start the engine, it doesn't start on its own, unless I press the gas. if I let go, it stalls, if it starts and I give it a couple of shots, I hear a whisslering noise.

so what shall I do?
I came to believe I need to re-check the gap on my spark plugs, I don't know what I can do more, could it be dirt in my cyclinders?

tell me what you think.
Thanks
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top