Pirate 4x4 banner
1 - 18 of 18 Posts

·
Registered
Joined
·
1,234 Posts
Discussion Starter · #1 ·
hey guys i'm attempting a HD steering on my TJ, the front is being swaped out to a D44, i'm using shakerbuilt arms and the big GM TREs that have a 7/8-18 shank, i need to know who i can get the left and right hand threaded inserts from, i have only come across PSC for the ends so far...

oh, one last thing.... is it possible to get the stock TJ pitman arm reamed to fit the GM ends?

thanks
Shalil
:beer:
 

·
Premium Member
Joined
·
78,528 Posts
Sharp said:
oh, one last thing.... is it possible to get the stock TJ pitman arm reamed to fit the GM ends?

thanks
Shalil
:beer:


Yes, you can ream the TJ pitman arm for those GM TRE's. I got one reamed
from Part Mike and put it on my 86CJ7. It cost me $49 cause I bought the
complete arm.
 

·
Registered
Joined
·
29,224 Posts
I would not use those 7/8" inserts if you are using 1.5" .25" wall tubing.

The threaded portion of the inserts are so thin, that after you weld them you can't screw the TRE inside. I guess the heat messes up the treads.

The only way my buddy ended up getting his TREs in was to tap the inserts after they were welded on. He spent god knows how much on taps, which defeats the purpose of buying the inserts.
 

·
Registered
Joined
·
2,475 Posts
TexasBlake said:
I would not use those 7/8" inserts if you are using 1.5" .25" wall tubing. Blah, Blah, Blah........

How about threading the TREs into the insert with plenty of anti sieze before welding them up :question: :D
 

·
Registered
Joined
·
713 Posts
TexasBlake said:
I would not use those 7/8" inserts if you are using 1.5" .25" wall tubing.

The threaded portion of the inserts are so thin, that after you weld them you can't screw the TRE inside. I guess the heat messes up the treads.

The only way my buddy ended up getting his TREs in was to tap the inserts after they were welded on. He spent god knows how much on taps, which defeats the purpose of buying the inserts.
built hi steer for 3 rigs now, and have not yet experienced that problem.

welded some with tre's in the inserts, some without, never any thread warpage.

you must have done something wrong...
 

·
Registered
Joined
·
4,456 Posts
TexasBlake said:
I would not use those 7/8" inserts if you are using 1.5" .25" wall tubing.

The threaded portion of the inserts are so thin, that after you weld them you can't screw the TRE inside. I guess the heat messes up the treads.
Worked fine for me and three or four others I know about who have used them.

Sounds like operator error on your buddies part to me.
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top