Pirate 4x4 banner

1 - 11 of 11 Posts

·
Registered
Joined
·
850 Posts
Discussion Starter #1
my TJ wont start. it was driving fine for the first part of the day. i parked uphill, turned it off; two minutes later it wont crank over. i checked the schrader valve on the fuel rail and nothing came out. so i am guessing the fuel pump went out. anything else it could be?
 

·
Registered
Joined
·
850 Posts
Discussion Starter #2
i wasnt that low on gas, so the fuel pickup should have reached despite the incline.
 

·
Registered
Joined
·
850 Posts
Discussion Starter #6
well knuckelhead, it wont start. the starter works just fine. there is not an inline filter. driving in the rain yesterday, didnt hit any puddles, but could it have just shorted out? it has been hard to start for a while, couple of months or so; was that my warning sign?
 

·
Registered
Joined
·
850 Posts
Discussion Starter #8
no. is there a way to check for the power and ground without dropping the tank? my Jeep is not here with me as of yet, and i am trying to research my problem before it gets here. thanks everyone.
 

·
Registered
Joined
·
850 Posts
Discussion Starter #9
so fuse number 21 keeps blowing. it blows when i turn the key to start it. thought that was my problem then it blew another fuse within a 20 trip...in the middle of the road no less. does this mean bad fuel pump? or bad wire splicing? bad ground? i see no bad wires anywhere.
 

·
Registered
Joined
·
5,450 Posts
sounds like the fuel pump.

Fuses blowing? What aftermarket electrical items have you done to cause this? Usually an electric aftermarket device of somesort spliced into the electrical system incorrectly can cause this. Or you just have plain bad luck.

But it really sounds like something is causing your fuel pump to a)fail or b) not kick on correctly. Go buy a chiltons manuel. they have high quality electrical schematics and how to chase down shorts in the system.

Good luck
 

·
Registered
Joined
·
850 Posts
Discussion Starter #11
bad luck you say? i always end up replacing engines sooner or later because they just seem to die. no real explanaition. the only aftermarket thing on there is daytime running lights, and also that 4.0L i swapped in to replace the 4 banger. it is a 98 model and i wouldnt doubt it is the pump. the jeep has worked great delivering mail everyday since january. january wasa when the swap took place. why now? it was working fine, then just quit...
 
1 - 11 of 11 Posts
Top