Pirate 4x4 banner
1 - 4 of 4 Posts

·
Registered
Joined
·
13,247 Posts
Discussion Starter · #1 ·
So, buttoning up my little CUCV axle project finally. Last thing for the 14bolt was to replace the hinky seals on the hubs. Sweet, I have my seals that I have left over from the last 3/4t GMC I had, they'll work. Tap tap, in it goes. Go to put the other one in, it just falls in. WTF!!

Compare the two, and the original is about... a good 1/32" bigger than the replacement, even though one of them fit just fine. Off to the parts store. The TRW replacement that they have listed for an '85 is the same size as the original.


so! Who wants to theorize on the mismatch? Motor pool hijinks? Different castings? Replacement part?

I can get the original part # tomorrow. I asked Highhonda for 14bolt hub seals, and they are what he gave me. One fit tight as a drum, the other just fell in, like that time in Tijuana with that dancer. :D
 

·
Registered
Joined
·
13,247 Posts
Discussion Starter · #3 ·
I'm saying the O.D. of the seals are different. I am going out in a second to check the part numbers....

Ok.

TRW part number 2081, which is visually the same size as the original

2.844 ID 3.944 OD .55 wide

Compared to SKF 28426, which only fit one side

2.844 ID 3.939 OD .55 wide




there you have it. :D
 

·
Registered
Joined
·
13,247 Posts
Discussion Starter · #5 ·
I apologize: I DO have a Timken, NOT a TRW seal, the 2081.

The one that didn't work in one side is an SKF 28426. Looks like .005" too small.
 
1 - 4 of 4 Posts
Top