Pirate 4x4 banner
1 - 6 of 6 Posts

·
Registered
Joined
·
9,106 Posts
Discussion Starter · #1 ·
Hey guys,

Good buddy of mine's '89 XJ started running like Crap yesterday morning - like the 4.0 is running on 3 cyl. It had been running perfectly before that. We changed the fuel filter - not it. He had done a thorough tune-up not long ago - plugs, wires, cap, Etc. look good. I couldn't spot any vac. lines loose - anybody got any ideas on any F.I. gizmo's that might be the problem?

When you have fuel pump problems, does it usually die alltogether, or could it be causing this?

Thankx! <IMG SRC="smilies/smile.gif" border="0">

[ 11-02-2001: Message edited by: 0ILBURNER ]
 

·
Registered
Joined
·
220 Posts
I don;t know the Renix 4.0's too well, so, my info might be poor, but first I would start by a "surgical" cleaning of the throttle body, meaning take the damn thing off the manifold entirely...clean well around the IAS motor (if eqipped) and remove any sensor ont he t-body and clean. On HO's, rough running is usually a clogged IAS motor cavity.

if the roughness is accompanied by hard or long starts, I'd replace the cps and or map sensor.

also, weak or arcing ignition coils can cause a miss
 

·
Registered
Joined
·
982 Posts
idle air control motor or possibly throttel position sensor, and possily map sensor
 

·
Registered
Joined
·
1,071 Posts
I just had the same problem with my Renix Equipped 2.5L and it turned out being the MAP sensor

Is yours running high?

How does it run when hot? Cold?

thanks
 

·
Registered
Joined
·
402 Posts
I battled the same damned problem a month or two ago. It turned out to be the vacuum line running to the MAP sensor. Mine was fried where it had been pinned against the manifold. I didn't pick it up because it was on the underside and the hose looked just fine from where I was looking. Give that a shot and try replacing the MAP if the hoses are fine. Are you running really rich too? You might also check the fuel pressure regulator.
 

·
Registered
Joined
·
576 Posts
pull the codes, and check the junk arround the oil filter that you may have disturbed, but the codes will probably tell you whats wrong.
 
1 - 6 of 6 Posts
Top